PSP hacking/modding F.A.Q. (Start Here!)

Discussion in 'PSP - Hacking & Homebrew' started by Rydian, Dec 5, 2010.

Dec 5, 2010
    • Member

    Rydian Resident Furvert™

    Member Since:
    Feb 4, 2010
    Message Count:
    27,886
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    Yes, all new 3000 models have 6.60 or later.

    If you get an earlier 3000 that's on 6.20 or below (or any 2000), then you can be sure that it can have a permanent hack installed.


    • Member

    Janthran Solarian

    Member Since:
    Sep 17, 2011
    Message Count:
    3,733
    Location:
    The Pacific Northwet
    Country:
    United States
    Ohey I have a question. What's the difference between HEN and CFW? As far as I can tell, all CFW does is enable homebrew.
    • Member

    Rydian Resident Furvert™

    Member Since:
    Feb 4, 2010
    Message Count:
    27,886
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    A HEN enables user-mode homebrew.

    A good CFW enables user-mode homebrew, kernel-mode homebrew, backup loading, system plugins, PSX support, and possibly more I can't think of off the top of my head.

    HENs are the first steps in opening up a device, but after hacks have progressed, simple HENs become obsolete, which is why they're not mentioned here (as PSP hacking is well past the HEN stage on all the current models and firmwares).
    • Member

    Disco New Member

    Member Since:
    Nov 10, 2006
    Message Count:
    226
    Location:
    Croatia
    Country:
    Croatia
    Hello, I have psp 2000 with permanent hack (5.50 prometheus gen4), what is the best CFW to put on it to play ps1 games, homebrew/emulators and psp games?

    Is ti true that the newer CFW doesn't need popsloader for ps1 games?
    • Member

    Rydian Resident Furvert™

    Member Since:
    Feb 4, 2010
    Message Count:
    27,886
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    The stuff listed in the hacking sticky is what you want.

    POPS support is built in to the PSP in general. POPSloader is not used to load PSX games (the name should be POPSchanger or something), it's used to switch the POPS version used, to fix compatibility issues.
    • Member

    KingBlank King of Nothing

    Member Since:
    Sep 17, 2008
    Message Count:
    327
    Location:
    NW of eternity and E of never
    Country:
    New Zealand
    I just bought a second hand PSP 3002 with firmware 660 so from what ive read my options are to either:
    downgrade to 620 to make the custom firmware run on startup or just run the custom firmware every time the system is rebooted?
    If I can downgrade to 620 I would like to try that.
    • Member

    Rydian Resident Furvert™

    Member Since:
    Feb 4, 2010
    Message Count:
    27,886
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    Yeah those are the options, and yeah you can try the 6.20 downgrade.
    • Newcomer

    Senbei Norimaki New Member

    Member Since:
    Dec 10, 2012
    Message Count:
    87
    Country:
    Pacific Ocean
    I had a hard time with that Hellcat tool because I couldn't find the option to install clean 5.0 firmware just 1.5. I basically found an alternate way to do it on an another forum that said replace some file in the VSH. I did that an was able to update to 6.60 with no problem. Now on permanent 6.60 pro c with no problems. Thanks.
    • Member

    Rydian Resident Furvert™

    Member Since:
    Feb 4, 2010
    Message Count:
    27,886
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    You do know you need to hit a certain key combo when it's loading to access the advanced menu that has the extra options, right?
    • Newcomer

    Senbei Norimaki New Member

    Member Since:
    Dec 10, 2012
    Message Count:
    87
    Country:
    Pacific Ocean
    Yeah I know that. I only saw clean ofw 1.5. Unless i messed up when I did the combo.
    • Member

    Rydian Resident Furvert™

    Member Since:
    Feb 4, 2010
    Message Count:
    27,886
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    If it was right it'd display a secondary warning before booting.
    • Newcomer

    KevTehNev New Member

    Member Since:
    Jun 3, 2009
    Message Count:
    36
    Country:
    United States
    I have a friend with a PSP 1000 and his CFW is 5.00 M33-6. I'm trying to help him update to 6.60 and it's CFW, but I can't seem to find any proper info on how to do so. Can anyone help with this?
    • Member

    Rydian Resident Furvert™

    Member Since:
    Feb 4, 2010
    Message Count:
    27,886
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    The softmod guide shows you how to wipe back to a clean 5.00 that will allow the OFW upgrade.
    • Newcomer

    MissRayvin New Member

    Member Since:
    Jan 22, 2013
    Message Count:
    2
    Country:
    United States
    Hello people! I'm a newb to hacking so I've been reading the faq here for about 30 minutes or so and there's a couple things I want to make sure of before committing to a hack for my psp 3001.

    First of all, I bought mine back in '09 so I'm pretty sure that the firmware it came with was 5.x, although from what I read it's not going to be too difficult to find out for sure. That said, I've been pretty faithful with updating it so it's now running 6.60. I'd also like to point out that my goal in hacking is to be able to play psp iso's. I am planning on doing the temporary hack so that I can still run the games I bought off the psn, so here's my questions:

    What conditions specificly will cause my psp to brick? -- I want to know so that I can do my best to avoid this due to being penniless atm

    Is it going to be a safer bet to attempt the 6.20 downgrade, or will the 6.60 hack simply fail if my mobo isn't supported?

    I keep seeing HEN and CFW come up and I understand that HEN is now outdated but will I need to install one of these in addtion to the PRO hack on the softhack guide thread?

    I may have more questions but at the moment these are all the ones I can think of. Any assistance of any kind is much appreciated and I hope you're all having a good winter so far.

    Yoroshiku onegaishimasu! ; )
    • Member

    Rydian Resident Furvert™

    Member Since:
    Feb 4, 2010
    Message Count:
    27,886
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    Follow the instructions in order (always uninstall the permanent patch alongside the hack itself when upgrading, etc.), and don't touch flash0. Seriously, don't touch it. Never. I don't care what anybody says, even people here who have been using homebrew for years have bricked a PSP by messing around in flash0. All the things you used to need to fiddle in flash0 for are done via plugins and homebrew nowadays, so if a guide is telling you to go into flash0, it'd outdated and should be ignored. I'm stressing this because there's so many old guides still around that involve it.

    If it's had 6.20 or less on it at some point in it's life, then the downgrade to 6.20 should work. If it won't the downgrader will just error out on you anyways.

    No, PRO is the CFW (and the CFW is an advanced form of HEN anyways).

    Sony stopped updating the PSP over a year ago, so the existing hacks have had plenty of time to mature.
    • Newcomer

    MissRayvin New Member

    Member Since:
    Jan 22, 2013
    Message Count:
    2
    Country:
    United States
    Thanks for your help Rydian, I attempted the 6.60 hack this morning and I'm happy to report huge sucess! I tested it out with soul calibur broken destiny and it ran/played fine : D
    Rydian likes this.
    • Member

    nukeboy95 Leave luck to heaven.

    Member Since:
    Aug 24, 2010
    Message Count:
    2,269
    Location:
    Hoenn
    Country:
    Pacific Ocean
    i just got a psp 1000 with 6.60 promod b10
    all but one game i put in the iso folder and videos i put in the video file show up as corrupted data why?
    • Member

    Rydian Resident Furvert™

    Member Since:
    Feb 4, 2010
    Message Count:
    27,886
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    Make sure the ISO files aren't corrupt, and don't have long filenames (keep them as short as you can).

    As for the video, the PSP has specific requirements (like most older things). MP4 in it's resolution at 24/30FPS, and I forgot the rest (but the resolution and video format are generally what's wrong).
    • Member

    nukeboy95 Leave luck to heaven.

    Member Since:
    Aug 24, 2010
    Message Count:
    2,269
    Location:
    Hoenn
    Country:
    Pacific Ocean
    its being weird if i remove all the iso and then add one it work but try adding two and only one shows
    i tryed playing some of the game that say its not corrupted and when i try to save the save corrupts
    • Member

    Rydian Resident Furvert™

    Member Since:
    Feb 4, 2010
    Message Count:
    27,886
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    Are you using an actual memory stick, or one of those fake adapters? I use the work "fake" liberally because real MicroSD->MSPD adapters haven't been produced in years, so any one you buy recently is fake.

SPONSORED LINKS
 

Share This Page