PS Vita Emulator Issues...

Discussion in 'PS Vita - Hacking & Homebrew' started by Rokku, Oct 10, 2017.

  1. Rokku
    OP

    Rokku GBAtemp Fan

    Member
    460
    8
    Oct 4, 2010
    United States
    I'm having issues with two of the emulators on my Vita, this version of SNES9xTYL (http://wololo.net/downloads/index.php/download/7904) and PicoDrive Version...1.9, I believe.

    Snes9x just crashes when it tries to load a specific ROM that works on PC-based emulators (Mega Man X3 patched with the Zero Project 3.1 hack) and PicoDrive sees my ROMs but can't actually load them.

    Any suggestions for help?
     
  2. Tom Bombadildo

    Tom Bombadildo Honk!

    pip Contributor
    GBAtemp Patron
    Tom Bombadildo is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    10,906
    11,088
    Jul 11, 2009
    United States
    I forgot
    I would suggest trying the various emulators on Retroarch for both of your issues. The emulators you're using aren't very up to date, and haven't been worked on since Retroarch has been released.
     
  3. Zukov

    Zukov Dinosaur

    Member
    228
    57
    Oct 2, 2016
    Chile
    Still... RetroArch checks compatibility against the NoIntro Rom proyect, so I don't think Project Zero will be one of their priorities. Either way, try RetroArch, I'm sure you will get better results with it.
     
  4. Rokku
    OP

    Rokku GBAtemp Fan

    Member
    460
    8
    Oct 4, 2010
    United States
    Can I run RetroArch on a 3.61 firmware Vita with ARK though? I should have mentioned that, sorry.
     
  5. Tom Bombadildo

    Tom Bombadildo Honk!

    pip Contributor
    GBAtemp Patron
    Tom Bombadildo is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    10,906
    11,088
    Jul 11, 2009
    United States
    I forgot
    Ah, you should have mentioned that.

    Retroarch does have builds for PSP, so you could still try that.
     
  6. Rokku
    OP

    Rokku GBAtemp Fan

    Member
    460
    8
    Oct 4, 2010
    United States
    Hmm, I put RetroArch in the same directory I had my previous emulators in and transferred it over with QCMA but all I get upon launching it is a black screen. I wonder why.
     
  7. esmjanus

    esmjanus Advanced Member

    Newcomer
    51
    21
    Feb 5, 2012
    Mexico
    Last edited by esmjanus, Oct 11, 2017
  8. Rokku
    OP

    Rokku GBAtemp Fan

    Member
    460
    8
    Oct 4, 2010
    United States
    The Snes9xTYL you gave me still crashes with a C1-2858-3 error when trying to load Zero Project 3.1 and PicoDrive doesn't like my MegaCD BIOS and thus won't load Sonic CD...
     
  9. Zukov

    Zukov Dinosaur

    Member
    228
    57
    Oct 2, 2016
    Chile
    Just to be clear... does this emulator load the original rom?
     
  10. Rokku
    OP

    Rokku GBAtemp Fan

    Member
    460
    8
    Oct 4, 2010
    United States
    Yeah, the original ROM works just fine. And the hacked ROM works just fine in ZSNES and Snes9x on the PC.
     
  11. Rokku
    OP

    Rokku GBAtemp Fan

    Member
    460
    8
    Oct 4, 2010
    United States
    Does anyone know what BIOS the Japanese version of Sonic CD requires? I have the jp_mcd2_921222 BIOS file but apparently that's the wrong one because Sonic CD won't run.
     
  12. esmjanus

    esmjanus Advanced Member

    Newcomer
    51
    21
    Feb 5, 2012
    Mexico
    I think that needs jp_mcd1_9112 or jp_mcd1_9111
     
    Panzer_Baboon likes this.
  13. Rokku
    OP

    Rokku GBAtemp Fan

    Member
    460
    8
    Oct 4, 2010
    United States
    It just says that no JAP BIOS files were found...despite the fact that they're in the PicoDrive folder. Tells me to see docs for details but I don't have any docs.