postLoader4

Discussion in 'Wii - Emulation and Homebrew' started by stfour, Jun 30, 2011.

  1. B.B.Link

    B.B.Link GBAtemp Regular

    Member
    122
    11
    Feb 6, 2013
    United States
    Colorado
    How do you set postloader to boot Nintendont for my Gamecube games? I don't see an option for it anywhere. I'm using the latest version of both apps.
     
  2. LinkFan16

    LinkFan16 I link them all

    Member
    410
    102
    Mar 15, 2009
    Gambia, The
    Support for the newest version of Nintendont is not integrated into Postloader as of yet, so GameCube games cannot be directly launched by PL.
     
  3. B.B.Link

    B.B.Link GBAtemp Regular

    Member
    122
    11
    Feb 6, 2013
    United States
    Colorado
    Well that's disappointing...........
     
  4. daxtsu

    daxtsu GBAtemp Guru

    Member
    5,546
    3,955
    Jun 9, 2007
    Antarctica
    I've more or less moved on to the 3DS, but I might give postLoader one or two last hurrahs in terms of updating it for the newer Nintendont versions. Maybe this weekend or something.
     
    MassiveRican, gig71 and AbdallahTerro like this.
  5. Zopenko

    Zopenko Link He come to town Come to save the Princess Z

    Member
    136
    239
    Mar 1, 2015
    Mexico
    Daxtsu before you close the lid on this awesome software, i would like to make a request. Could it be possible to have the pointer start at the "center" of the screen, similar as the wii home screen?, or could you tell me what part of the code can i modify to accomplish this (last time I tried, I offseted the pointer glove image not the actual pointer). and thank you for this great revision that you did!
     
  6. daxtsu

    daxtsu GBAtemp Guru

    Member
    5,546
    3,955
    Jun 9, 2007
    Antarctica

    I'll see what I can do.
     
  7. daxtsu

    daxtsu GBAtemp Guru

    Member
    5,546
    3,955
    Jun 9, 2007
    Antarctica
    postLoader 4.7.96
    * postLoader now supports booting Nintendont via argsboot.
    * postLoader will no longer boot Nintendont versions lower than 1.98 (due to implementing argsboot, and removing the code for overwriting nincfg.bin).
    * postLoader will now print Nintendont version information in the debug log, if Nintendont 3.324 or newer is found.
    * PostLoader's autoupdate server has moved, and has been updated accordingly (my unofficial builds are still not on there, though).

    https://github.com/thedax/postloader/releases/download/4.7.96/postLoader.4.7.96.zip

    This is mostly a Nintendont only update. I'm still looking into how to move the cursor to the middle of the screen when it starts. Please let me know if you run into any issues with the new argsboot stuff.




    On the Gamecube games area (press up on the Dpad to toggle between Wii/GC), press start and change GC mode to Nintendont.
     
    Taleweaver and AbdallahTerro like this.
  8. BITBURGER

    BITBURGER GBAtemp Regular

    Member
    165
    5
    Dec 5, 2014
    Netherlands
    Kerkrade
    Thank you for this nice release it works so fine with Virtual VC Wiiware Games and most of all the Cheats plenty good work
    ** Mister **
     
  9. B.B.Link
    This message by B.B.Link has been removed from public view by BORTZ, Apr 27, 2015, Reason: you cannot say that.
    Apr 23, 2015
  10. AbdallahTerro

    AbdallahTerro da KiNG

    Member
    6,047
    2,520
    Jan 14, 2012
    Ideas factory :)
    thanks for the update,
    would it be possible to replace "use HID device" with "Use MC Multi" since the former is always enabled now and the latter is missing
     
  11. daxtsu

    daxtsu GBAtemp Guru

    Member
    5,546
    3,955
    Jun 9, 2007
    Antarctica
    Sure. I can just force it on in the next update, I suppose (just remove the option and logical OR it into the config). That wouldn't cause problems with original Wiis trying to use GC controls, right?
     
  12. AbdallahTerro

    AbdallahTerro da KiNG

    Member
    6,047
    2,520
    Jan 14, 2012
    Ideas factory :)
    yeah HID in nintendont is same as BT, available on demand
     
  13. ploder

    ploder Advanced Member

    Newcomer
    62
    0
    Jul 20, 2014
    Having some problems getting postloader to recognise my PAL emunand with NTSC vc and wiiware channels installed. I have postloader 4.7.4 on sd and 4.6.1 (from Abz's PAL mastermod premade emunand) installed in usb1:/nands/pln2o emunand and neither can see the channels, they just show blank tiles and at top of screen it is still using real nand. I can't see any way of switching to use neek2o nand from postloader config. At the bottom of postloader I can either choose 'neek' on the right (which switches to my neek2o nand with the vc and wiiware channels visible and playable - but is restricted to the 40 or so channel limit) or 'config', which says 'change uneek nand' (which displays a warning: "cannot open sd://ploader/plneekdir uneek nands folder must be in usb://nands or plneek.dol isn't in sd root or priibooter.dol isn't updated (0,0)").

    I tried to follow the read me guides, but didn't find them clear on how to achieve my goal. I do not want priibooter or anything interrupting my real system menu. All I want to do is start out on my real nand's system menu and then use homebrew channel to boot postloader from sd and then display over 100 vc and wiiware channels from Abz's pln2o emunand on usb. The reason is that I heard neek2o has the best compatibility.

    I know these channels are legit because I am currently playing my VC and wiiware channels from USB Loader GX's emunand loading ability and they also work from Neek2o's system menu, but find I have glitchy sound (distorted and unclear, like it is being put through a rough filter) especially on N64 games like Wave Race and Mario Golf. Interestingly, for example, Majora's Mask NTSC has glitchy sound, but the PAL version doesn't, but I don't want PAL vc games if possible because in general they were notorious for being 50hz only (I currently force PAL60 on all my NTSC games so I can have the option of native 480p should I ever use a HDTV and component cables). I can't use NTSC emunand because I am using official RGB scart and that would lead to red tint display problem.

    As I say I am probably missing a file/s. If what I want to do isn't possible in postloader then I am willing to try alternatives. My ultimate goal is to display more than 48 channels and play the best version of VC & Wiiware titles from an emunand over RGB scart.
     
  14. LinkFan16

    LinkFan16 I link them all

    Member
    410
    102
    Mar 15, 2009
    Gambia, The
    Does anybody else have problems downloading postLoader.4.7.96 from GitHub? On my side nothing happens when I click on the link. I also tried right clicking it and choosing "save target as...", but that doesn't work either.
     
  15. daxtsu

    daxtsu GBAtemp Guru

    Member
    5,546
    3,955
    Jun 9, 2007
    Antarctica

    Works fine here. If you're still having trouble, try getting it from the Releases page.
     
  16. LinkFan16

    LinkFan16 I link them all

    Member
    410
    102
    Mar 15, 2009
    Gambia, The
    Thanks for the tip but I tried that already, no dice, at least not on my end. Lately I had all kinds of problems downloading things from different sources, not just GitHub. So it seems something on my end is broken or just not working right. Maybe sooner or later I will be able to find what causes these problems.
     
  17. daxtsu

    daxtsu GBAtemp Guru

    Member
    5,546
    3,955
    Jun 9, 2007
    Antarctica
    Could simply be a browser issue. Maybe try Chrome or something if you're using Firefox/IE?
     
  18. LinkFan16

    LinkFan16 I link them all

    Member
    410
    102
    Mar 15, 2009
    Gambia, The
    Yes, I am using firefox as my browser of choice. But installing Chrome really did the trick and I could finally download the file. So thanks again :-)
     
    daxtsu likes this.
  19. lepicane

    lepicane Advanced Member

    Newcomer
    66
    3
    Oct 29, 2011
    Thanks for the update. Unfortunately still refuses to start on my emu nand (as per my previous posts).

    Oh well, never mind.....keep up the good work.
     
  20. daxtsu

    daxtsu GBAtemp Guru

    Member
    5,546
    3,955
    Jun 9, 2007
    Antarctica
    I'm not really sure why it doesn't boot for you, sorry. I haven't used any emuNAND features on the Wii in literally years, and I haven't touched anything related to that code since I started these unofficial updates, so I have no idea what it might be. The only thing I could possibly think of would be that I use an updated devkitPro/PPC, but unless it has some sort of huge compiler bugs or something, I don't see why that would affect it.
     
  21. game_rat

    game_rat Advanced Member

    Newcomer
    93
    8
    Feb 7, 2011
    United States
    Just curious, has anyone successfully tested neek2o functionality with any of the daxtsu releases? I can no longer launch games in neek2o mode and I can no longer use the nand switching option. This could very well be something on my end so just wondering if anyone else is having the same problem?