[Old Method] Kafluke's All-in-One for self hosting

Discussion in 'Wii U - Hacking & Backup Loaders' started by Kafluke, Apr 30, 2016.

  1. Kafluke
    OP

    Kafluke GBAtemp Psycho!

    Member
    3,961
    1,911
    May 6, 2006
    United States
    I tried to update it yesterday but it wouldn't let me delete or overwrite any files. Maybe some did delete. I sent @Cybernatus a message.
     
  2. lingedy

    lingedy Newbie

    Newcomer
    8
    1
    Feb 21, 2017
    Indonesia
    please restore it asap, lots of people need it. thanks in advance
     
  3. Kafluke
    OP

    Kafluke GBAtemp Psycho!

    Member
    3,961
    1,911
    May 6, 2006
    United States
    Ok, fixed and updated. Thanks again @Cybernatus for helping out.
     
  4. Codemastershock

    Codemastershock Advanced Member

    Newcomer
    91
    26
    Oct 14, 2013
    Brazil
    I know it have CFWs and such that makes self-hosting practically useless, but I don't have the funds to buy a decent SD Card and the NDS vulnerable game.
    Most of my games I bought, I use loadiine only for japanese games....

    I use Linux Mint and used Ubuntu for some time and you can self-host in these systems, it's very easy.

    First, you have to know if your system is 32 or 64 bits. On terminal, you can with this line:

    uname -m

    - If you are running a 32 bit system, insert this line:
    Code:
    wget http://liquidtelecom.dl.sourceforge.net/project/xampp/XAMPP%20Linux/7.0.6/xampp-linux-7.0.6-0-installer.run -O xampp-installer.run
    
    - If you are running in a 64 bit system, insert this instead:

    Code:
    wget https://ufpr.dl.sourceforge.net/project/xampp/XAMPP%20Linux/7.0.13/xampp-linux-x64-7.0.13-1-installer.run -O xampp-installer.run
    
    - Give execution permissions to properly run the installer:

    chmod +x xampp-installer.run

    - Start the installation process with

    sudo ./xampp-installer.run

    - When finished, create a shortcut inside the menu with one of these commands

    32 bits
    echo -e '[Desktop Entry]\n Version=1.0\n Name=xampp\n Exec=gksudo /opt/lampp/manager-linux.run\n Icon=/opt/lampp/icons/world1.png\n Type=Application\n Categories=Application' | sudo tee /usr/share/applications/xampp.desktop

    64 bits
    echo -e '[Desktop Entry]\n Version=1.0\n Name=xampp\n Exec=gksudo /opt/lampp/manager-linux-x64.run\n Icon=/opt/lampp/icons/world1.png\n Type=Application\n Categories=Application' | sudo tee /usr/share/applications/xampp.desktop

    In some distros, you need to install GKSU for the shortcut to work properly
    sudo apt-get install gksu or sudo apt install gksu in newer distros

    Now, copy all the contents of the wiibrew folder inside the /opt/lampp/htdocs and start the program and the Apache services.
     
    Last edited by Codemastershock, Feb 21, 2017
    lordelan and Kafluke like this.
  5. Kafluke
    OP

    Kafluke GBAtemp Psycho!

    Member
    3,961
    1,911
    May 6, 2006
    United States
    Sweet! Great info for Linux users!
     
  6. lingedy

    lingedy Newbie

    Newcomer
    8
    1
    Feb 21, 2017
    Indonesia
    "updated", what's the difference between before and after? is it still the same? i don't need to update memory card's contents as well, right? it's still homebrew launcher 1.3 isn't it? if there are differencess please let me know,
     
  7. Kafluke
    OP

    Kafluke GBAtemp Psycho!

    Member
    3,961
    1,911
    May 6, 2006
    United States
    There is a changelog in the OP. It's basically two things,

    1. Added mocha
    2. Updated to HBL 1.4

    Yes you'll need to update your sd files
     
  8. lingedy

    lingedy Newbie

    Newcomer
    8
    1
    Feb 21, 2017
    Indonesia
    i tried to visit loadiine.ovh/kafluke using my wiiu but it freezed. that's because i hadn't updated my sd files.
    then i visited loadiine.ovh instead, manually i picked HBL 1.3 and it worked.

    my question is, in order to enter HBL 1.4 using your updated direct link loadiine.ovh/kafluke, what updated files should i put inside my sd?
    would you please give me download link for the updated files and let me know where should i put those files? (root directory or inside which folder)
     
  9. Kafluke
    OP

    Kafluke GBAtemp Psycho!

    Member
    3,961
    1,911
    May 6, 2006
    United States
    It's all in post number one. Just download the update package (the one without PC files) and that will have the updated SD files (really you just need HBL and mocha updated)
     
  10. FelipeInhaquite

    FelipeInhaquite Newbie

    Newcomer
    1
    0
    Mar 1, 2017
    Brazil
    can you put the new 2.2 files for download? I really want to use the new portal in my local server.
     
  11. Kafluke
    OP

    Kafluke GBAtemp Psycho!

    Member
    3,961
    1,911
    May 6, 2006
    United States
    They are there in the OP. I was talking about the online version that I couldn't upload
     
  12. Madridi

    Madridi Card Collector

    Member
    3,161
    975
    May 9, 2008
    Qatar
    Doha
    @Kafluke
    So I just downloaded this. I'll be testing it later, but here are some suggestions:

    - I suggest removing ftpiiu_everywhere. I assume the version you included is the one to launch with cbhc, but there is another version of the app to launch if you're using mocha. Due to the app using nand functions, I suggest you take it out to eliminate such problems

    - I was against it in the past, but I think it's time: Remove 5.3.2 and 5.4.0 from this package. At the time, no IOSU hack, cfw, or even brazilian method was out, and while there were assurances that IOSU will work on 5.5.1, I can understand why people would want to stay at a lower firmware possible, and this AIO package accomodated that. Now though, there is literally no reason whatsoever to stay on a lower firmware, especially now that the Wii U has reached the end of it's life
     
  13. Madridi

    Madridi Card Collector

    Member
    3,161
    975
    May 9, 2008
    Qatar
    Doha
    @Kafluke
    HBL loading through PHP doesn't seem to be stable (failed 2 out of 2). So I compared hbl folders between that and the earlier release, and it seems the mp4 payloads are different. I tried the older payload and it launches 1.4 flawlessly
     
  14. Kafluke
    OP

    Kafluke GBAtemp Psycho!

    Member
    3,961
    1,911
    May 6, 2006
    United States
    Good info. I'm sick as a dog right now so I won't be messing with this too much
     
  15. Madridi

    Madridi Card Collector

    Member
    3,161
    975
    May 9, 2008
    Qatar
    Doha
    I also found some weird issue with mocha integration. It works the way it is, but not with a stripped down version I'm making.

    Hope you feel better soon.

    Edit:
    Actually, it seems that loading mocha is not stable at all..
    A weird thing I found, that I get about 40% success rate the way it is. However, if I move it in the json file below hbl and loadiine, it fails everytime.

    In all cases, it's not stable here
     
    Last edited by Madridi, Mar 12, 2017
  16. Madridi

    Madridi Card Collector

    Member
    3,161
    975
    May 9, 2008
    Qatar
    Doha
    @Kafluke
    Following my last post, I got rid of the messy mocha folder. I converted the code550.bin to an mp4 (which means we can use it in both MP4 and PHP sections now), and coupled that the brilliant php script from @Cybernatus making it point to the MP4. This method gives me roughly 80% success rate. It's still not perfect, but it's much better than we currently have (not to mention cleaner)

    Just quote me when you feel better, and we can discuss this for a better release perhaps
     
  17. Psygnosis

    Psygnosis Advanced Member

    Newcomer
    54
    0
    Jul 25, 2009
    Italy
    I don't get the difference between php exploit and mp4.
    I just tried the mp4 version with kws (android) and everything works (not 100% success rate like php).
    If I want to serve php files through android can you advice me an app to do this? it seems kws can't.
     
  18. Kafluke
    OP

    Kafluke GBAtemp Psycho!

    Member
    3,961
    1,911
    May 6, 2006
    United States
    It can. Just download the PHP version.

    Php seems to have more success because the code pauses to load the mp4 completely
     
    Psygnosis likes this.
  19. Psygnosis

    Psygnosis Advanced Member

    Newcomer
    54
    0
    Jul 25, 2009
    Italy
    ok, i did some try today with the new 2.2 package here is the result.

    The HBL PHP loader fails 99% of the try. the only way I menage to load it is to take the payload 551 mp4 from @Kafluke 2.1 package and substitute it with the new one in the 2.2 package.
    In this way I could load HBL 1.4 with 100% success rate. (I don't know if it load the elf or the rpx either the 2 files are in the hbl folder on the sd card).

    Mocha for me loads 80% of the times, but I have an issue that if mocha is loaded I cannot load hbl. I will ask this on the right thread I don't think is a problem of this package.
     
  20. Kafluke
    OP

    Kafluke GBAtemp Psycho!

    Member
    3,961
    1,911
    May 6, 2006
    United States
    Thanks for the feedback! I don't know many people that aren't using HaxChi these days so I don't get much feedback on the self host package. I'd be happy to test and report back. I haven't used it in so long I don't even know what works and what doesn't these days

    — Posts automatically merged - Please don't double post! —

    I know the last time I tested it everything was working great. Maybe clear your internet cache and try again
     
    KiiWii and Psygnosis like this.