Luma3DS - Noob-proof 3DS Custom Firmware

Discussion in '3DS - Flashcards & Custom Firmwares' started by Aurora Wright, Jan 19, 2016.

Thread Status:
Not open for further replies.
  1. nl255

    nl255 GBAtemp Addict

    Member
    2,571
    360
    Apr 9, 2004
    There is a converter as well as pre-converted d9wip/hg9 payloads here:http://gbatemp.net/threads/tutorial...derhax-payloads-to-firms.471144/#post-7319608 . Note that I did minimal testing with the payloads so make a nand backup with gm9 before doing anything potentially dangerous.
     


  2. Lilith Valentine

    Lilith Valentine GBATemp's Wolfdog™ I drool on my knife

    Member
    19,754
    20,498
    Sep 13, 2009
    Antarctica
    Between insane and insecure
  3. sks316

    sks316 Retro Enthusiast

    Member
    1,500
    720
    Nov 28, 2013
    United States
    Hyrule
    1. Yes.
    2. If you're using Hamcha's updater, it's broken and you need to get @KunoichiZ's updater. If you're using @KunoichiZ's updater, get the latest update from the GitHub and you should be good to go!
    3. If you mean the CTRNAND-based Luma installation, yes.
    I apologise, but I do not understand 4 and 5.
     
    Last edited by sks316, May 20, 2017 - Reason: added the link to KunoichiZ's Luma Updater.
  4. Ryumaru

    Ryumaru Creator of themes for 3DS

    Member
    2,387
    1,033
    Feb 1, 2015
    Brazil
    Even with this modification, the protection of the A9LH was maintained ?
     
  5. Sonic Angel Knight

    Sonic Angel Knight GBAtemp Guru

    Member
    9,829
    4,917
    May 27, 2016
    United States
    New York
    1. Okay then
    2. Okay i will check
    3. I see....
    4. Before renaming arm9loaderhax.bin to "arm9loaderhax_si.bin" Will make the screen flash when is booting. How do i do that with this bootstrap9 stuff now?
     
    Last edited by Sonic Angel Knight, May 20, 2017
  6. sks316

    sks316 Retro Enthusiast

    Member
    1,500
    720
    Nov 28, 2013
    United States
    Hyrule
    I believe so. According to @addi33:
    — Posts automatically merged - Please don't double post! —

    4. I don't believe that has been looked into. arm9loaderhax.bin/arm9loaderhax_si.bin don't work with boot9strap because boot9strap uses boot.firm.
     
    Februarysn0w likes this.
  7. KunoichiZ

    KunoichiZ GBAtemp Guru

    Member
    7,865
    3,130
    Mar 16, 2012
    United States
    Last edited by KunoichiZ, May 20, 2017
    Jubash, Sev501, a9lh-1user and 3 others like this.
  8. Ryumaru

    Ryumaru Creator of themes for 3DS

    Member
    2,387
    1,033
    Feb 1, 2015
    Brazil
    This new payload will replace the arm9loaderhax ?
     
  9. KunoichiZ

    KunoichiZ GBAtemp Guru

    Member
    7,865
    3,130
    Mar 16, 2012
    United States
    boot.firm (SigHax/Boot9strap) replaces arm9loaderhax.
     
  10. sks316

    sks316 Retro Enthusiast

    Member
    1,500
    720
    Nov 28, 2013
    United States
    Hyrule
    Yes, boot.firm will boot instead of arm9loaderhax.bin and/or arm9loaderhax_si.bin. You will need to manually delete arm9loaderhax.bin and/or arm9loaderhax_si.bin.
     
  11. Sorathehero2

    Sorathehero2 Member

    Newcomer
    11
    0
    Apr 13, 2017
    I have a problem of updating Luma3DS to 7.1 where it can not find the arm9loaderhax.binFATAL
     
  12. addi33

    addi33 GBAtemp Advanced Maniac

    Member
    1,656
    711
    Sep 12, 2016
    Gambia, The
    • boot9strap support (all older entrypoints, including ARM9LoaderHax and menuhax, are no longer supported).
    • Replaced .bin (brahma/a9lh) payload loading with .firm (FIRM format) payloads. This format allows for way more flexibility and is also the only one supported by boot9strap.
     
  13. Sorathehero2

    Sorathehero2 Member

    Newcomer
    11
    0
    Apr 13, 2017
    So how do I update now
     
  14. addi33

    addi33 GBAtemp Advanced Maniac

    Member
    1,656
    711
    Sep 12, 2016
    Gambia, The
  15. YupItsJocey

    YupItsJocey Member

    Newcomer
    17
    2
    Aug 23, 2014
    United States
    Hello, I recently installed Luma3DS with a long overdue update from MenuHax + EmuNand and now that I have Luma, I can't access my friend's list due to freezing. What do I do?
     
  16. ombus

    ombus GBAtemp Regular

    Member
    143
    30
    Dec 28, 2015
    United States
    its necessary to have arm9loaderhax to update to boot9strap to still have luma updates ? i have menuhax on 9.2 with latest emunand.
     
  17. Sonic Angel Knight

    Sonic Angel Knight GBAtemp Guru

    Member
    9,829
    4,917
    May 27, 2016
    United States
    New York
    Okay, i officially dropped hamcha luma updater in favor of yours, thank you very much. :)

    Now if homebrew launcher can just get working again, had i know it wasn't i might have waited before updating luma. :unsure:

    Can you also add the updater to TitleDB.com so we can update it with fbi installer without QR codes?
     
    KunoichiZ likes this.
  18. sks316

    sks316 Retro Enthusiast

    Member
    1,500
    720
    Nov 28, 2013
    United States
    Hyrule
    Homebrew Launcher isn't working? Have you tried the 11.2 payloads?
    Also, I already submitted it to TitleDB, but the changes haven't been made yet.
     
  19. Sonic Angel Knight

    Sonic Angel Knight GBAtemp Guru

    Member
    9,829
    4,917
    May 27, 2016
    United States
    New York
    I been using 11.2 for months, i stop updating since there was no more reason to update. No it doesn't work, every time i load, is a red screen, i am forced to reboot.
     
    a9lh-1user likes this.
  20. sks316

    sks316 Retro Enthusiast

    Member
    1,500
    720
    Nov 28, 2013
    United States
    Hyrule
    Update to 11.4 and try again. I can't help on an outdated firmware because it's a firmware I never used Homebrew on.
     
Thread Status:
Not open for further replies.