[List] Games required Firmware version

Discussion in 'Switch - Hacking & Homebrew' started by B4rtj4h, Oct 5, 2017.

  1. B4rtj4h
    OP

    B4rtj4h Gaming addict #2 and some

    Member
    616
    123
    Apr 16, 2007
    Netherlands
    Bikini Bottom
    This is NOT true. As anybody must know Super Mario Odyssey needs at least firmware 3.0.1. This firmware is also delivered with the cartridge. If you update the game it won't run until you have firmware 4.0.0 installed.
     
  2. ShadowOne333

    ShadowOne333 GBAtemp Guru

    Member
    7,355
    4,783
    Jan 17, 2013
    Mexico
    Has anyone been able to confirm what firmware updates does the Resident Evil Revelations Collection come with?
     
  3. Arnold101

    Arnold101 GBAtemp Regular

    Member
    106
    1
    May 19, 2006
    United States
    installed firmware 3.0. Waiting some cool hacking news...
     
  4. B4rtj4h
    OP

    B4rtj4h Gaming addict #2 and some

    Member
    616
    123
    Apr 16, 2007
    Netherlands
    Bikini Bottom
    Bad news there as they are both downloadable titles. So expect 3.0.2 or even higher.
     
  5. Arnold101

    Arnold101 GBAtemp Regular

    Member
    106
    1
    May 19, 2006
    United States
    there is a official topic here about pegaswitch or switch hacking?
     
  6. ShadowOne333

    ShadowOne333 GBAtemp Guru

    Member
    7,355
    4,783
    Jan 17, 2013
    Mexico
  7. B4rtj4h
    OP

    B4rtj4h Gaming addict #2 and some

    Member
    616
    123
    Apr 16, 2007
    Netherlands
    Bikini Bottom
  8. rac

    rac Member

    Newcomer
    15
    0
    Dec 27, 2014
    United States
    i bought the explorer's edition zelda and it did not require firmware higher than 3.0.0. the game was on 1.0.0.

    was this not true for other explorer editions? because now i'm wondering if my copy was tampered with and maybe replaced with a regular edition then returned to the store.
     
  9. Sepioth

    Sepioth Newbie

    Newcomer
    1
    0
    Dec 2, 2017
    United States
    Came here topost same thing :) Mine is a US cart though so slight serial change :P

    Cartridge LA-H-ADENB-USA
    Contains the FW Update 3.0.2
    (Switch was on FW 3.0.1)
     
  10. Lyxnn

    Lyxnn Newbie

    Newcomer
    2
    0
    Dec 2, 2017
    Spain
    So we need to be on 3.0.2 or can we play at 2.3.0?
     
  11. badpix11

    badpix11 Member

    Newcomer
    17
    11
    Mar 14, 2017
    Serbia, Republic of
    Fairy World
    The FW on a Cartridge will force an update to play the game, so 3.0.2
     
    Lyxnn likes this.
  12. Xyphoseos

    Xyphoseos Hack or no games

    Member
    1,021
    87
    Jun 29, 2016
    France
    Rivière
    Minecraft and minecraft story mode are eshop games ? Im on 3.0.0, I can't buy/download it ?
    Or there is a way ?
     
  13. badpix11

    badpix11 Member

    Newcomer
    17
    11
    Mar 14, 2017
    Serbia, Republic of
    Fairy World
    The list are required firmware for cartridge version, so you may have to look for an online retailer like amazon.
    eShop Games, always require the last firmware version to get them.
     
    B4rtj4h and Xyphoseos like this.
  14. worm28

    worm28 GBAtemp Advanced Fan

    Member
    710
    134
    Jun 2, 2013
    United States
    Xyphoseos likes this.
  15. Lyxnn

    Lyxnn Newbie

    Newcomer
    2
    0
    Dec 2, 2017
    Spain
    Oh thanks :( im going to wait a bit more
     
  16. cracker

    cracker Nyah!

    Member
    3,173
    463
    Aug 24, 2005
    United States
  17. ThisIsDaAccount

    ThisIsDaAccount GBAtemp Advanced Fan

    Member
    820
    388
    Apr 8, 2016
    United States
    Does anyone know the required version for Lego Marvel Super Heroes?
     
  18. PoppaDre

    PoppaDre GBAtemp Regular

    Member
    168
    59
    Aug 23, 2016
    Canada
    does anyone know if the snipperclips cartridge can be played on 1.0?
     
  19. B4rtj4h
    OP

    B4rtj4h Gaming addict #2 and some

    Member
    616
    123
    Apr 16, 2007
    Netherlands
    Bikini Bottom
    No it can't. Since the DLC is included I assume it is 3.0.1 or higher. Since I do not have access to a Switch with 1.0.0. I can't confirm.
     
  20. PoppaDre

    PoppaDre GBAtemp Regular

    Member
    168
    59
    Aug 23, 2016
    Canada
    ahh that's too bad. thought it would be a fun game to get my gf into