[List] Games required Firmware version

Discussion in 'Switch - Hacking & Homebrew' started by B4rtj4h, Oct 5, 2017.

  1. Nah3DS

    Nah3DS Madre de Dios! Es El POLLO DIABLO!!!

    Member
    3,670
    1,948
    Feb 9, 2010
    Argentina
    Does anyone knows the firmware version of Tiny Barbarian DX?
     
  2. PlasticK

    PlasticK Newbie

    Newcomer
    6
    0
    Oct 4, 2017
    Russia
    Xenoblade Chronicles 2?
     
  3. epickid37

    epickid37 ( ͡° ͜ʖ ͡°)

    Member
    535
    432
    Jan 4, 2017
    United States
    why would i tell you stalkers where i live?
    sonic mania is on there twice, and it's called the binding of isaac afterbirth+
     
    B4rtj4h likes this.
  4. B4rtj4h
    OP

    B4rtj4h Gaming addict #2 and some

    Member
    554
    99
    Apr 16, 2007
    Netherlands
    Bikini Bottom
    Corrected it in the list! Thnx for reporting :).
     
  5. 2Hack

    2Hack HYPiavelli

    Member
    2,166
    4,888
    Nov 26, 2014
    Canada
    Underground
    but the original fw expectation? Or is the game unplayable without the update?
     
  6. ShadowOne333

    ShadowOne333 GBAtemp Guru

    Member
    7,266
    4,701
    Jan 17, 2013
    Mexico
    Has there been any word on what firmware does Doom come with?
     
  7. B4rtj4h
    OP

    B4rtj4h Gaming addict #2 and some

    Member
    554
    99
    Apr 16, 2007
    Netherlands
    Bikini Bottom
    No if you buy the game on disc you do not need to update.

    As for Doom, I think it will come with at least 3.0.2+.
     
  8. Ceuse

    Ceuse Advanced Member

    Newcomer
    59
    27
    Jul 23, 2017
    Germany
    Can confirm that snipperclipers plus works on 3.1 no idea lower sadly
     
    B4rtj4h likes this.
  9. B4rtj4h
    OP

    B4rtj4h Gaming addict #2 and some

    Member
    554
    99
    Apr 16, 2007
    Netherlands
    Bikini Bottom
    That would prove a lot of people wrong! Because they say that when a game is updated it automatically needs the newest firmware. :unsure:
     
  10. Ceuse

    Ceuse Advanced Member

    Newcomer
    59
    27
    Jul 23, 2017
    Germany
    Updated my switch from 2.3 to 3.1 through odysey and noe just inserted snipperclippers plus from the physical release. Works
     
    B4rtj4h likes this.
  11. yahoo

    yahoo G͝B͢A͜t͞em҉p̡ R̨e͢g̷ul̨aŗ

    Member
    344
    238
    Aug 4, 2014
    United States
     
  12. ShadowOne333

    ShadowOne333 GBAtemp Guru

    Member
    7,266
    4,701
    Jan 17, 2013
    Mexico
    So still no word/confirmation on what Doom comes with? XD
     
  13. ootnes2

    ootnes2 GBAtemp Regular

    Member
    198
    39
    Oct 26, 2015
    United States
    I am Setsuna is spelled wrong and should be listed under “2.3 and under” (it is available as a cart from Japan, with full english support) and not 3.0.0.
     
    B4rtj4h likes this.
  14. irliey

    irliey Newbie

    Newcomer
    2
    2
    Tuesday
    Malaysia
    Just Dance 2017 can run on v1.0.0
     
    B4rtj4h likes this.
  15. B4rtj4h
    OP

    B4rtj4h Gaming addict #2 and some

    Member
    554
    99
    Apr 16, 2007
    Netherlands
    Bikini Bottom
    I really doubt that! Because I had to update my Splatoon Switch to play it.
    But I lowered the firmware to 2.3.0 and lower :). Thanks for reporting!
     
    Last edited by B4rtj4h, Nov 14, 2017 at 8:51 AM
  16. irliey

    irliey Newbie

    Newcomer
    2
    2
    Tuesday
    Malaysia
    mine is v1.0.0 bundle with Just dance 2017. can play. no issue.

    got this from reddit

    Game Firmware
    1-2-Switch 1.0.0
    Arms 2.1.0
    Cars 3: Driven to Win
    Cave Story + 1.0.0
    Disgaea 5 Complete 1.0.0
    Dragonball Xenoverse 2 2.1.0
    Fate/Extella: The Umbral Star
    FIFA 18 3.0.1
    Fire Emblem Warriors 3.0.1
    Has Been Heros 1.0.0
    I Am Setsuna 1.0.0
    Just Dance 2017 1.0.0
    Lego City Undercover 1.0.0
    Mario + Rabbids: Kingdom Battle 2.1.0
    Mario Kart 8 Deluxe 1.0.0
    Minecraft: Story Mode - The Complete Adventure
    Monster Hunter XX 2.1.0
    Pokkén Tournament DX 3.0.0
    Puyo Puyo Tetris 1.0.0
    Rayman Legends 3.0.0
    Retro City Rampage DX
    Sine Mora EX
    Skylanders: Imaginators 1.0.0
    Splatoon 2 2.3.0
    Super Bomberman R 1.0.0
    Super Mario Odyssey 3.0.1
    The Binding of Isaac: Afterbirth + 1.0.0
    The Legend of Zelda: Breath of the Wild 1.0.0
    Troll & I
    Ultra Street Fighter II The Final Challengers
     
    Last edited by irliey, Nov 15, 2017 at 12:25 AM
    B4rtj4h likes this.
  17. ShadowOne333

    ShadowOne333 GBAtemp Guru

    Member
    7,266
    4,701
    Jan 17, 2013
    Mexico
    So Rayman Legends also comes with 3.0.0?
    What about Doom? Is there any word on what firmware it comes with?
     
  18. B4rtj4h
    OP

    B4rtj4h Gaming addict #2 and some

    Member
    554
    99
    Apr 16, 2007
    Netherlands
    Bikini Bottom
    Doom is already in the list!

    Thank you very much :D
     
  19. Manurocker95

    Manurocker95 Game Dev & Pokémon Master

    Member
    683
    181
    May 29, 2016
    Spain
    Madrid
    L.A Noire Remastered, at least 4.0.0.
    Seems you can run it without the update.
     
    Last edited by Manurocker95, Nov 15, 2017 at 2:10 PM
    B4rtj4h and ShadowOne333 like this.
  20. ShadowOne333

    ShadowOne333 GBAtemp Guru

    Member
    7,266
    4,701
    Jan 17, 2013
    Mexico
    Just saw it.
    It's 4.0.0 :(
    Well, another one bites the dust, everything for keeping my 2.3.0 intact XD