Just got a new 3DS XL with an R4i (www.r4ids.cn), getting an error message?

Discussion in '3DS - Hacking & Homebrew' started by thebatdadd, Jun 26, 2013.

Jun 26, 2013
    • Newcomer

    thebatdadd New Member

    Member Since:
    Jun 26, 2013
    Message Count:
    20
    Country:
    United States
    Hi there, new to the forum and I need help installing my r4i. I just picked up a 3DS XL (still sealed) with an r4i (looks exactly like this one: http://www.r4-ds-au.com/product_images/uploaded_images/R4i Gold 3DS New Label.jpg, its www.r4ids.cn) and unfortunately my 3DS XL is 6.0.0.11U, so the r4i needs to be updated. I downloaded the WOOD 1.60 kernel update along with the 6.0 patch, extracted the files from them to my formatted 16 GB sandisk ultra micro sd card (while keeping the R4iGold_3DS60_Patch_NDSi_3DS.nds and deleting the other one), and then when I put the micro sd card in my r4i and try to run it on my XL (it thinks the cart is konami digital entertainment), and just get an error message on the bottom screen saying "An error has occurred. Press and hold the power button to turn the system off. Please refer to the Nintendo DSI operations manual for details". Any help? I have no idea what I am doing wrong...
    • Member

    Yamagushi New Member

    Member Since:
    May 2, 2013
    Message Count:
    167
    Country:
    United States
    You just bought a 3ds pre-loaded with 6.0.0? Surely you let it update? That would be insanely quick to get that update not only to stores, but have sold off all old systems and begun to stock them.
    • Member

    slingblade1170 New Member

    Member Since:
    Mar 15, 2009
    Message Count:
    624
    Country:
    United States
    You gotta use a DSPhat, DSLite, DSi with older firmware or a 3DS that hasn't been updated to 6.0.0.whatever. If you got a 2nd DS/3DS or can use a friends for a few minutes then update the kernel, afterwards your 3DS XL should boot the R4i just fine.
    • Newcomer

    thebatdadd New Member

    Member Since:
    Jun 26, 2013
    Message Count:
    20
    Country:
    United States
    Aw man, I don't really know anyone who owns a DS around me at the moment. Is this really a necessary step? And if so, do you think it would be worth it to just buy an updated r4i card? They just released a new r4i gold that apparently already works with the 6.0.0-X...or maybe a used DSphat or Lite...

    And yes, that is my firmware for sure. I don't know, I did use the eshop and download a few demos so maybe that somehow updated it or something? All I know is that when I check my system settings, that's what firmware it says on the bottom right of the top screen.
    • Member

    slingblade1170 New Member

    Member Since:
    Mar 15, 2009
    Message Count:
    624
    Country:
    United States
    I have had to use an older DS so many times due to those cards. To answer your question, yes. You have to update it on older firmware or else the R4i will be a no go. As for buying a new one, if you got the cash do it, then sell your current one to get your money back.
    • Member

    Rydian Resident Furvert™

    Member Since:
    Feb 4, 2010
    Message Count:
    27,885
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    Yes, using the eshop will update you. A 3DS with a flash cart is not a good combo if you want to still use the online features like that.
    • Member

    Yamagushi New Member

    Member Since:
    May 2, 2013
    Message Count:
    167
    Country:
    United States
    Doesn't R4i gold have some sort of usb update dongle?
    • Member

    LurkerA ㊣Gold 3DS㊣

    Member Since:
    Apr 8, 2010
    Message Count:
    219
    Country:
    United States
    • Newcomer

    thebatdadd New Member

    Member Since:
    Jun 26, 2013
    Message Count:
    20
    Country:
    United States
    Thanks for the replies guys, sorry to bump this but one more quick question. I want to pick up a second DS on the cheap so that I can update the r4i (I'd rather just get another DS used for $15-45 than the usb updater, that way I'll have a backup DS too), but just wondering, can the 1st generation 'phat' DS be used to update the r4i card? Or does it have to be a Lite or DSi model? I have a lead on a phat one for really cheap one but just want to be sure it'll work first for what I want to do before picking it up. Also, can the r4i card be used on the phat DS? or only the 3DS? Thanks!
    • Member

    Vengenceonu Happy Holidays

    Member Since:
    Jun 20, 2013
    Message Count:
    1,525
    Location:
    GBATemp EOF
    Country:
    United States
    Any Ds can be used to update it, from phat all the way to dsi xl (providing you didnt update to the latest firmware for the xl like you did the 3ds.) but ds lite is best i think, so get that
    • Member

    Rydian Resident Furvert™

    Member Since:
    Feb 4, 2010
    Message Count:
    27,885
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    Yes, the fat can be used just as well as the lite, and flash carts work on it.
    • Newcomer

    thebatdadd New Member

    Member Since:
    Jun 26, 2013
    Message Count:
    20
    Country:
    United States
    Good to hear, thanks for the help everyone!

Share This Page