I can't load games off my USB drive

Discussion in 'Wii - Hacking' started by Ehab, Dec 29, 2016.

Dec 29, 2016
  1. Ehab
    OP

    Newcomer Ehab Advanced Member

    Joined:
    Aug 9, 2013
    Messages:
    54
    Country:
    United States
    my friend gave me a wii system a few days ago, and I decided to hack it, so I'm fairly new at this.
    I managed to install the homebrew channel, and a bunch of apps for it, including the 3 usb loaders I could find. GX, configurable, and wiiflow, using this page. gx always crashes after a little bit of time, wiiflow works best, but doesn't show all of the games. I was trying to rip games from real disks, but none of the loaders could accomplish that. wiiflow doesn't progress at all, configurable freezes, and gx starts at 100% and freezes. though I could play games that I downloaded from the USB drive. In my attempt to fix that, I installed every IOS I could find, but still couldn't fix that. After that, whenever I attempt to load a game, it freezes while booting the games. I need your help! is there a way to fix this?
     


  2. Ehab
    OP

    Newcomer Ehab Advanced Member

    Joined:
    Aug 9, 2013
    Messages:
    54
    Country:
    United States
    ok, something weird is going on
    when I first got the wii, gamecube games worked perfectly fine on it. Now, whenever I load up a gamecube retail disc, it shows the dios mios logo, and depending on the game, it either loads it, partially loads it (I can go through the menus, and watch cutscenes, but I get a black screen as soon as the gameplay starts), or just shows a black screen. Any idea why this is happening?
     
  3. x65943

    Member x65943 Hobby Artist

    Joined:
    Jun 23, 2014
    Messages:
    2,208
    Location:
    Indiana
    Country:
    United States
    You replaced your mios file with diosmios. This is what happens when you "install every IOS I could find". Do you have a nand backup from when you started? You may want to start from scratch.

    Edit: Look in the tutorials section https://gbatemp.net/forums/wii-tutorials.235/
     
    Last edited by x65943, Dec 29, 2016
  4. Ehab
    OP

    Newcomer Ehab Advanced Member

    Joined:
    Aug 9, 2013
    Messages:
    54
    Country:
    United States
    I have a keys.bin and nand.bin
    though I don't know what to do with them
     
  5. x65943

    Member x65943 Hobby Artist

    Joined:
    Jun 23, 2014
    Messages:
    2,208
    Location:
    Indiana
    Country:
    United States
    Last edited by x65943, Dec 29, 2016
  6. Ehab
    OP

    Newcomer Ehab Advanced Member

    Joined:
    Aug 9, 2013
    Messages:
    54
    Country:
    United States
    I believe I used bootmii
     
  7. x65943

    Member x65943 Hobby Artist

    Joined:
    Jun 23, 2014
    Messages:
    2,208
    Location:
    Indiana
    Country:
    United States
    bootmii should have an option to restore the nand. You should check.
     
  8. Ehab
    OP

    Newcomer Ehab Advanced Member

    Joined:
    Aug 9, 2013
    Messages:
    54
    Country:
    United States
    that link you posted for the tutorial is the same one I followed (see original post), and I couldn't install any games with that setup, which is why I installed all of the stuff I did
    do you have an explanation as to why that happened? so that I could prevent it next time?
     
  9. x65943

    Member x65943 Hobby Artist

    Joined:
    Jun 23, 2014
    Messages:
    2,208
    Location:
    Indiana
    Country:
    United States
    When you say that you couldn't install games, what do you mean?

    Wiiflow works just fine for me. What exactly do you mean when you say that all the games would not show in wiiflow? Did you make sure to update the cache once you installed new games?
     
  10. Ehab
    OP

    Newcomer Ehab Advanced Member

    Joined:
    Aug 9, 2013
    Messages:
    54
    Country:
    United States
    as I stated in the original post, configurable usb loader would freeze trying to install a game, usb loader gx would start at 100% progress bar, and I wouldn't be able to press anything, so I would have to reset the console, and as for wiiflow, the progress bar wouldn't change, but in some situations I could go back, so it doesn't always freeze.
    and as for wiiflow not showing all the games, I have 3 games on my usb stick. It shows the first 2, but not the third one I added yesterday. I don't know how to update the cache, and for some reason, whenever I click on the button that switches the source (USB/SD/...etc), the app crashes
     
  11. B451CW11M0DD3R

    Newcomer B451CW11M0DD3R Member

    Joined:
    Dec 29, 2016
    Messages:
    49
    Country:
    United States
    hold on i got a thread for this 1 sec
     
  12. x65943

    Member x65943 Hobby Artist

    Joined:
    Jun 23, 2014
    Messages:
    2,208
    Location:
    Indiana
    Country:
    United States
    Wiiflow's cache has to be updated each time you add a game, I can't remember exactly how to do it, but it's very easy. In the options there should be a listing "refresh cache".
     
  13. B451CW11M0DD3R

    Newcomer B451CW11M0DD3R Member

    Joined:
    Dec 29, 2016
    Messages:
    49
    Country:
    United States
    https://gbatemp.net/threads/help-need-help-loading-wii-games-with-usb-loader-gx.372021/
    look at this thread and keep scrolling down it helped me when I tried installing games off USB
    same with 659 USB Loader GX works perfectly for me but I think it has to do with you installing all those ISO's
    I'll show you what my SDHC card looks like and what I have on it
    also try using WiiBackUpManager not WBSF Manager ( WBSF Manager is outdated)

    IMAGES
    [​IMG]
    https://gyazo.com/df46dcb843881e146576af0a2d62ec46

    [​IMG]
    https://gyazo.com/eb219502727833148596db57d41758f2


    ( you don't have to install the stuff on there im just showing you what I have )
     
    Last edited by B451CW11M0DD3R, Dec 30, 2016
  14. Ehab
    OP

    Newcomer Ehab Advanced Member

    Joined:
    Aug 9, 2013
    Messages:
    54
    Country:
    United States
    I just noticed that I had an outdated version of wiiflow -_-
    just updated it, and now I can actually click on things without it freezing, and I found the reload cache button. I also attempted installing multiple games, and so far only the one gamecube game I tested installed. NSMBW froze at 9%, and the game that wouldn't start was super mario galaxy, which I found out that is broken (the wii can't load the disc, though it shows the icon in the disk channel).
    since I'm now under the impression that the issues I'm having are due to disk/usb sticks I'm using, I took a look at all the wads I installed, and there's only one file with the "mios" letters in it, which is the diosmios wad. Do I still have to recover the nand? or can I remove it and install it again/update it to fix the issue?
     
  15. GreyWolf

    Member GreyWolf GBAtemp Addict

    Joined:
    Mar 2, 2015
    Messages:
    2,870
    Country:
    United States
    That usually means it couldn't write to the drive. If it's a flash drive you'll probably have to dump the games with Cleanrip to an SD card then transfer them over because flash drives are pretty crappy on the Wii. If it's a HDD it may not be completely compatible and you can either use the same method if the custom IOS you installed for Wii games can't write to the drive either.

    You can replace DIOS MIOS with the original MIOS if you want. ModMii can download it for you.
     
    x65943 likes this.
  16. Ehab
    OP

    Newcomer Ehab Advanced Member

    Joined:
    Aug 9, 2013
    Messages:
    54
    Country:
    United States
    any good tutorials on installing ModMii?
     
  17. x65943

    Member x65943 Hobby Artist

    Joined:
    Jun 23, 2014
    Messages:
    2,208
    Location:
    Indiana
    Country:
    United States
  18. Ehab
    OP

    Newcomer Ehab Advanced Member

    Joined:
    Aug 9, 2013
    Messages:
    54
    Country:
    United States
    soo all I have to do is download MIOSv10 from ModMii and install it, and it would replace dios mios/revert it back?
     
  19. John_Ice

    Member John_Ice GBAtemp Regular

    Joined:
    Sep 14, 2009
    Messages:
    171
    Location:
    No one has gone before
    Country:
    Canada
    Can you post a Syscheck because we don't have very details about what you did wrong.
     
  20. GreyWolf

    Member GreyWolf GBAtemp Addict

    Joined:
    Mar 2, 2015
    Messages:
    2,870
    Country:
    United States
    x65943 likes this.

Share This Page