How To Softmod (Hack) Your PSP

Discussion in 'PSP - Hacking & Homebrew' started by Rydian, May 23, 2011.

  1. TULOA

    TULOA Member

    Newcomer
    44
    2
    Oct 22, 2007
    United States
    Out of curiosity if anyone knows did they come up with a fix to the 6.61 Pro C2 bug where it didnt play PSX games?

    Just got able to get another replacement screen and button panel and trying to set it back up and im on a Dark Alex CFW but I wasnt sure what CFW to use that will have full features like my current one does.
     


  2. arq

    arq Member

    Newcomer
    44
    14
    Sep 20, 2015
    Finland
    Just checking:

    I got my girlfriend's old PSP (model number PSP-1004, so old euro-PHAT) with firmware version 5.4.

    I would like to set temporary CFW on the console. So I guess I should update the firmware, which should not have any problems with my model? The FAQ's here point to firmware version 6.60, but the current from official Sony site is 6.61. Do the CFW here work for 6.61 or should I search for the older 6.60 instead?

    Also, is there possibility of bricking my console with the firmware patch or CFW, and if yes, is there a way to recover from it?
     
    Last edited by arq, Aug 1, 2017
  3. arq

    arq Member

    Newcomer
    44
    14
    Sep 20, 2015
    Finland
    Okay, I tried with first updating my PSP-1004 to 6.60 and then updating CFW.

    I installed 6.60 without any problems. Update was completed and System Settings now show my version as 6.60. Then I dumped 6.60 PRO (from the first post) to the PSP/GAME/ folder. When I try to run the PROUPDATE, the screen shows PSP logo, then goes black, and finally gives "The game could not be started (80020148)" error. After that I tested with 6.60 PRO-C fix 3.

    It worked fine. Until I restarted my PSP, and tried Fast recovery. Which gives me same 80020148 error.

    How to avoid the error? Does installing CFW again break anything, if i just run the proupdate again? Should I just run the proupdate and then cipl and go with the permanent hack (provided that cipl does not give me the same error)?

    (I am using 16gb microsd with Memory Stick adapter, could that have anything to do with it? The 16gb microsd has worked fine in other use)
     
    Last edited by arq, Aug 2, 2017
  4. Flame

    Flame Me > You

    Member
    3,829
    4,941
    Jul 15, 2008
    dont know why alot of as of late is getting this problem 80020148

    proupdate and then run permanent hack and you should be good to go.