[HOW-TO] Setup Custom Firmware w/ SigPatches

Discussion in 'Wii U - Tutorials' started by iAqua, Oct 30, 2016.

?

Were you successful in installing redNAND?

  1. Yes, it worked perfectly.

    169 vote(s)
    67.9%
  2. Yes, but with some hiccups.

    31 vote(s)
    12.4%
  3. No, and I bricked.

    34 vote(s)
    13.7%
  4. No, it didn't work, but I didn't brick! :)

    15 vote(s)
    6.0%
  1. punderino

    punderino aka Big-Dick Swinger

    Member
    868
    481
    Jan 5, 2016
    United States
    Kansas City, Missouri
    qq tfw my "work" gets stolen
     


  2. godreborn

    godreborn GBAtemp Psycho!

    Member
    3,194
    591
    Oct 10, 2009
    United States
    well, many of us know u did it, so we all owe u credit for that. I like system config tool more than wup installer anyway which is y I used it.
     
  3. punderino

    punderino aka Big-Dick Swinger

    Member
    868
    481
    Jan 5, 2016
    United States
    Kansas City, Missouri
    nah, it was just a change of like, 4 numbers and a repack. but i do love attention, so thanks <3
     
    godreborn likes this.
  4. godreborn

    godreborn GBAtemp Psycho!

    Member
    3,194
    591
    Oct 10, 2009
    United States
    well, it's appreciated. btw, do u know y save injection doesn't work with that version of System Config Tool? there's no option to inject a save once u've selected the wii u's serial number. it shows the option in the documents u sent me.

    edit: the documents r using a different version though, so maybe a bug?
     
  5. dosmosis

    dosmosis Newbie

    Newcomer
    2
    0
    Mar 25, 2017
    United States
    I'm currently installing redNAND via Mocha. Prior to this I had painstakingly installed all my backups on to a USB hard drive via WUP Installer. My question is this, once I've completed installing redNAND with Haxchi will my installs still be on the sytem menu available to play? Also, when it comes to VC and eShop titles once the CFW is setup can these be installed on to the system menu via WUP Installer as well?
     
  6. tieuhoanglinh

    tieuhoanglinh Member

    Newcomer
    10
    0
    Dec 10, 2016
    Hi everyone,
    I installed redNand and then Haxchi on sysNand. Now the Haxchi only show in sysNand, and when I boot in redNand the Haxchi's icon becomes '?' , and if I need to go to HBL( installing game, homebrew, etc...) i still have to go through the website process... Is there anyway to make the Haxchi appears in redNands too?
     
  7. jbuck1975

    jbuck1975 GBAtemp Advanced Fan

    Member
    867
    183
    Dec 28, 2015
    United States
    Its because you made rednand then installed haxchi. Rednand is a copy of sysnand.
     
  8. tieuhoanglinh

    tieuhoanglinh Member

    Newcomer
    10
    0
    Dec 10, 2016
    yeah i thought so too... but I did follow this tutorial , and the redNand is listed before haxchi... Do you know how to fix this ?
    Should i just download the game again in redNand and install haxchi in redNand ?
     
  9. nexusmtz

    nexusmtz GBAtemp Maniac

    Member
    1,251
    433
    Feb 17, 2016
    United States
    I'm going to guess that you have a USB drive. If you installed it to system storage (as it says in the instructions) while booted under sysNAND, you wouldn't see it on a redNAND that you created before that install.
    As long as you haven't installed CBHC, remove the game while booted under sysNAND, then install it to system storage and run the Haxchi installer. (if it's on USB, you could just move it to system storage.) Reboot to redNAND, install it to system storage and run the Haxchi installer.

    It would be best to not use redNAND unless have a reason for using it, but if you must, you have to understand how it affects your installations.
     
  10. tieuhoanglinh

    tieuhoanglinh Member

    Newcomer
    10
    0
    Dec 10, 2016
    Oh i've just figured out why. I've installed the game in sysmemory in sysnand and then run haxchi. Later on i booted into rednand. While it's still loading i cut the connection to nintendo update server by turn on the firewall on my wlan router. The game, as I purchased, should be automatically downloaded but the connection is blocked, so the '?' icon means the programm isn't complettly downloaded yet.
    But it should work now. Thank you very much :)
    and yeah i've heard so much that cfw sysnand is much better than rednand ( why i still couldn't tell) but like CBHC , cfw sysnand has a small percentage of bricking the wii U, so I, as a noob, would rather play it safe...
     
  11. nexusmtz

    nexusmtz GBAtemp Maniac

    Member
    1,251
    433
    Feb 17, 2016
    United States
    So to be safe, you're going to continue to use the browser to launch redNAND, but you're going to use Haxchi under redNAND to launch homebrew instead of just installing the channel version of Homebrew Launcher on redNAND?

    Or are you going to use Haxchi on sysNAND to launch Mocha/redNAND, and use Haxchi on redNAND for HBL? I'm not sure what kind of brick avoidance that would give you.
     
  12. Jhynjhiruu

    Jhynjhiruu GBAtemp Fan

    Member
    454
    92
    Dec 31, 2016
    So will I brick if I install this version of SysConfigTool to SysNAND?
     
  13. muff_diving_101

    muff_diving_101 Newbie

    Newcomer
    9
    0
    Apr 5, 2017
    United States
    Hey guys, I have a quick question for you. I just set up my console with redNAND Mocha + Haxchi. I used the sdio nand manager to extract all 5 of the files necessary to have a backup. My question is: If my redNAND crashes or corrupts, how do I restore the backup? I understand you use the manager to inject the files, but do I format the SD and then Inject each file 1 by 1? Or do I not format the SD and just inject each file 1 by 1? And when injecting the files in what order do I inject them?

    Thank you guys in advance, I feel like I'm overcomplicating this but I just want to be certain I am doing it properly.
     
  14. omanitztristen

    omanitztristen Member

    Newcomer
    15
    0
    Apr 6, 2017
    United States
    After I formatted my SD card with redNAND, I powered the Wii U off and inserted my SD card back to my computer. Once I opened the card all of the folders were erased somehow. I copied the wiiu folder back onto the SD card as specified and now it seems I'm back at step 1 and it is asking me to format for redNAND again. Please help? I'm new to all of this so pardon my ignorance.
     
  15. muff_diving_101

    muff_diving_101 Newbie

    Newcomer
    9
    0
    Apr 5, 2017
    United States
    Which setup are you using? HBL or Haxchi? And also, when you say that you "let it format your sd card with redNAND" Did you do the full dump? It should on the black screen with white text said something along the lines of "SD format successful" Then you would have gone through a multiple hour dumping process. Did that happen?
     
    Last edited by muff_diving_101, Apr 6, 2017
  16. omanitztristen

    omanitztristen Member

    Newcomer
    15
    0
    Apr 6, 2017
    United States
    Yes I went through the dumping process and I'm just using HBL I haven't tried with HAXCHI yet. I just did it a second time and it said it was successful again but as soon as i powered down the wiiU and took the card out it was empty again.
     
  17. muff_diving_101

    muff_diving_101 Newbie

    Newcomer
    9
    0
    Apr 5, 2017
    United States
    How long did the dump take?
    First things first. This may sound dumb, but make sure that the switch on your SD card is not in the lock position. Check that switch and make sure it is unlocked. If it already is we will move on to the next option.

    Right after you click your mocha.elf file in your HBL, hold B in order to bring up the configuration screen. Your settings should look exactly like this

    • Config view mode: expert
    • Skip the menu on launch: on
    • Show launch image: on
    • Don't relaunch OS: off
    • Launch System Menu: on
    • redNAND: on
    • SEEPROM redirection: on
    • OTP redirection: on
    • Use syshax.xml (coldboothax): off
    If it looks like this hit A, then if it tries to dump the NAND again we need to check your partition. You will need to download the MiniTool Partition Wizard. https://www.partitionwizard.com/

    Open this program with your SD card in the PC and you should have a partition on there that says "unallocated" and it will be about the size of your Wii U internal memory. Post a screen shot of it if you can. Then we will go from there.

    — Posts automatically merged - Please don't double post! —

    Oh and btw it is normal for all the files to be erased on the SD card. When you press the power button to start the dumping process it formats your SD card first then injects a hidden partition on the drive, which is a copy of your sysNAND. This is called your redNAND, or "Redirected NAND" due to it being a clone.
     
    Last edited by muff_diving_101, Apr 6, 2017
  18. omanitztristen

    omanitztristen Member

    Newcomer
    15
    0
    Apr 6, 2017
    United States
    So I did what you said and it no longer dumped anything it went back to the home screen as soon as i pressed A. Am I now good to install sysconfig?
     
  19. muff_diving_101

    muff_diving_101 Newbie

    Newcomer
    9
    0
    Apr 5, 2017
    United States
    You should be in redNAND now but we need to make sure that you are. The easiest way to do this (this is the way I have it set up and it's really nice to have) is to follow these steps.

    1) Power off your Wii U and power it back on in order to get you to a non-cfw environment. Make a folder that is titled "sysNAND" and leave the color theme blue.
    2) Go to your HBL and boot into your Mocha redNAND. When you do, the folder you created named sysNAND should be gone. This means you are in your redNAND environment. Now, just as we did earlier, created a folder and name it redNAND (making the color scheme red) If done properly you will now have folders indicating which environment you are in.

    After this you should be able to install your sysconfig tool while in your redNAND environment. But I do need to ask, why are you wanting the sysconfig tool? This is usually used for more advanced applications and can be quite dangerous to use if you do not know what you are doing. If you are simply wanting to play downloaded games then you have no need for the sysconfig tool.
     
  20. nexusmtz

    nexusmtz GBAtemp Maniac

    Member
    1,251
    433
    Feb 17, 2016
    United States
    If you're simply playing games, you don't need redNAND either.