How to make my "bricked" R4i-3DS work on a DSi?

Discussion in 'NDS - Flashcarts and Accessories' started by pandavova, Aug 14, 2017.

  1. pandavova
    OP

    pandavova @pandavova FOLLOW ME ON TWITTER

    Member
    634
    288
    Oct 27, 2015
    Germany
    Windows 10 Pro
    I have a R4i 3DS from the Website "r4i-sdhc.com". If i boot the Card normal i get a screen that says "Please upgrade the Hardware for support latest firmware". I tried with many Firmware versions, a NDS Lite and the "White Screen" Fix (which said "Unknown Chip"). It works on my New 3DS XL with a special Launcher and YSMenu 7.04RGF.
    I would prefere to use it on my DSi LL cause of the (very good) Quality compared to a New 3DS XL.
    My Question is now: Can i get this card on my DSi LL to work without a Hardmod? Maybe that it boots automatic with the YSMenu (or something better)?

    The Card
     
    Last edited by pandavova, Aug 14, 2017
  2. Technicmaster0

    Technicmaster0 GBAtemp Psycho!

    Member
    3,142
    647
    Oct 22, 2011
    Gambia, The
    Can you post a picture of the card itself?
     
  3. pandavova
    OP

    pandavova @pandavova FOLLOW ME ON TWITTER

    Member
    634
    288
    Oct 27, 2015
    Germany
    Windows 10 Pro
    [​IMG]
     
  4. Technicmaster0

    Technicmaster0 GBAtemp Psycho!

    Member
    3,142
    647
    Oct 22, 2011
    Gambia, The
    And it shows the error if you try to boot the "R4i-SDHC 3DS kernel download"?
     
  5. pandavova
    OP

    pandavova @pandavova FOLLOW ME ON TWITTER

    Member
    634
    288
    Oct 27, 2015
    Germany
    Windows 10 Pro
    What?


    Its in the imgur gallery, its this what pops up:
    Normal Boot

    And btw, press on the "R4i 3DS" its the pic of that card, so it was there and you didn't seen it... I added it now to the bottom cause of you lol
     
  6. Technicmaster0

    Technicmaster0 GBAtemp Psycho!

    Member
    3,142
    647
    Oct 22, 2011
    Gambia, The
    Can you download the "R4i-SDHC 3DS kernel download" and extract the content of the archive to the microSD in the r4? (but it might be wise to make a backup of the sd's content first).
     
  7. pandavova
    OP

    pandavova @pandavova FOLLOW ME ON TWITTER

    Member
    634
    288
    Oct 27, 2015
    Germany
    Windows 10 Pro
    Do you even know what you talking about?
     
  8. Technicmaster0

    Technicmaster0 GBAtemp Psycho!

    Member
    3,142
    647
    Oct 22, 2011
    Gambia, The
    Yes but it's clearly a kernel problem and not a firmware problem because the card boots. You would get an "an error occured" screen if it was a firmware problem.
     
  9. bananapi761

    bananapi761 Lurkin

    Member
    148
    24
    Jan 8, 2016
    United Kingdom
    Norn Iron
    I owned that cart years ago, and if I remember correctly they released an 'RTS' version that you need if you want to use it on recently new DS versions or new R4 firmware updates. If you are trying to use it on a DSi, then try downloading a update for the flashcart that is a few years old.
     
  10. pandavova
    OP

    pandavova @pandavova FOLLOW ME ON TWITTER

    Member
    634
    288
    Oct 27, 2015
    Germany
    Windows 10 Pro
    thats the same... the firmware is the "kernel"

    I tried many zips with different firmware/kernel versions. Even on a DS Lite this card shows this...
     
    Last edited by pandavova, Aug 14, 2017
  11. Technicmaster0

    Technicmaster0 GBAtemp Psycho!

    Member
    3,142
    647
    Oct 22, 2011
    Gambia, The
    Wrong. The firmware is stored on the flash chip inside of the flashcard (2MB for most flashcards). The kernel is stored on the MicroSD card.

    Maybe you find a working one at https://filetrip.net/nds-downloads/...oad-r4i-sdhc-english-kernel-1-68b-f31980.html. You can change the version if you click on "Other versions: 16".
     
  12. nastys

    nastys ナースティス

    Member
    1,487
    864
    Aug 5, 2014
    Italy
    Earth
    It might just be your date and time settings. Some kernels "expire" after a while, requiring you to update it. I'm not kidding.
     
  13. pandavova
    OP

    pandavova @pandavova FOLLOW ME ON TWITTER

    Member
    634
    288
    Oct 27, 2015
    Germany
    Windows 10 Pro
    Lowest "kernel" i could find is 1.35b, and its not working...



    Yeah i know, but this didn't help...