How to install missing Xbox One UWP Dependencies

Discussion in 'Xbox One - Tutorials' started by wiired24, Jul 24, 2017.

  1. wiired24
    OP

    wiired24 GBAtemp Advanced Fan

    Member
    771
    536
    Sep 3, 2013
    United States
    Dev_Home
    Disclaimer - When we can we always try to provide you the necessary dependencies for homebrew. However we can not account for absolutely everything the end user may want or try to sideload to their Xbox One Console. Which is why a dependency pack is needed.




    So you're trying to sideload an application in dev mode and you get an error that looks a bit like this

    Installation Progress
    Failure reason: Windows cannot install package someapplication_1.2.3.0_x64__b6z97r9dfatj6 because this package depends on a framework that could not be found. Provide the framework "Microsoft.Advertising.Xaml" published by "CN=Microsoft Corporation, O=Microsoft Corporation, L=Redmond, S=Washington, C=US", with neutral or x64 processor architecture and minimum version 10.1705.4.0, along with this package to install. The frameworks with name "Microsoft.Advertising.Xaml" currently installed are: {Microsoft.Advertising.Xaml_10.1703.1.0_x64__8wekyb3d8bbwe}. Failure text: Package failed updates, dependency or conflict validation. (0x80073cf3)


    This is caused by not having the needed dependencies for the application and this error is very common. In this tutorial I will explain how you can easily fix these error messages and get your homebrew sideloaded on to the Xbox One console.


    1. Download the dependency pack, it contains all the dependencies you need.
    http://www.mediafire.com/file/eypyi2mjwmx11me/dependencies.7z

    2. Once downloaded go ahead and extract the .zip archive


    3. Open the Xbox One Dev Portal and select the homebrew application or game you wish to sideload.

    [​IMG]

    4. When it asks for dependencies you will go to wherever you downloaded the dependency pack and navigate to and select the appropriate dependency.


    Once you have added the missing dependency and your application or game should now work.

    Enjoy :yayone:


    @dominater01 Your welcome
     
    Last edited by wiired24, Jul 24, 2017
    TheVinAnator and dominater01 like this.
  2. dominater01

    dominater01 GBAtemp Fan

    Member
    424
    191
    Mar 13, 2009
    United States
    these could be sorted better and just have a folder and appx because thats all we need
     
    Last edited by dominater01, Jul 24, 2017
  3. wiired24
    OP

    wiired24 GBAtemp Advanced Fan

    Member
    771
    536
    Sep 3, 2013
    United States
    Dev_Home
    Sorry
     
  4. dominater01

    dominater01 GBAtemp Fan

    Member
    424
    191
    Mar 13, 2009
    United States
    i trimmed it for you will be up soon

    im not pissed off im just saying i found about 200mb worth of usless stuff
     
    wiired24 likes this.
  5. wiired24
    OP

    wiired24 GBAtemp Advanced Fan

    Member
    771
    536
    Sep 3, 2013
    United States
    Dev_Home
    Okay cool, I'll replace the link with the cut down version
     
  6. dominater01

    dominater01 GBAtemp Fan

    Member
    424
    191
    Mar 13, 2009
    United States
    Last edited by dominater01, Jul 24, 2017
    wiired24 likes this.
  7. wiired24
    OP

    wiired24 GBAtemp Advanced Fan

    Member
    771
    536
    Sep 3, 2013
    United States
    Dev_Home
    dominater01 likes this.
  8. dominater01

    dominater01 GBAtemp Fan

    Member
    424
    191
    Mar 13, 2009
    United States
    im not sure if its some weird error but everytime a game asks for vclibs it sez its out of date when running the game
     
    wiired24 likes this.
  9. wiired24
    OP

    wiired24 GBAtemp Advanced Fan

    Member
    771
    536
    Sep 3, 2013
    United States
    Dev_Home
    I have no clue why. That's strange