How to install dvdx on wii?

Discussion in 'Wii - Hacking' started by limesherbert, Nov 6, 2008.

Thread Status:
Not open for further replies.
Nov 6, 2008
    • Member

    limesherbert New Member

    Member Since:
    Oct 15, 2008
    Message Count:
    143
    Country:
    United States
    Right so I downloaded DVDX installer (end users) from here but then when I extracted that .rar file all I got was boot.dol and no installer.dol like the hackmii post said. [IMG] so now what.

    and sorry for the noobish question >_>
    • Member

    Arm the Homeless Custom Title

    Member Since:
    May 26, 2008
    Message Count:
    1,762
    Location:
    /home/andy/
    Country:
    United States
    I can tell you're new to this.

    Put boot.dol in /apps/dvdx/ and run in HBC.
    • Member

    limesherbert New Member

    Member Since:
    Oct 15, 2008
    Message Count:
    143
    Country:
    United States
    mkay did that, but once I loaded up homebrew channel the app showed up with no title, no icon, no descroption. It just said apps/dvdx/boot.dol. So I just loaded it up, and I got to something called 'dvd stub installer' or something along those lines. I did a normal install, which took about two seconds, and then I went back to HBC. I'm not sure I have dvdx because when I tried loading a DVD in mplayer it didn't work.
    • Member

    Arm the Homeless Custom Title

    Member Since:
    May 26, 2008
    Message Count:
    1,762
    Location:
    /home/andy/
    Country:
    United States
    You don't need title, icon, or description.

    Nobody needs meta.xml files or icon.png

    DVDX worked, but you need to right MPlayer from HackMii and use a factory-made DVD if possible to test.
    • Newcomer

    BennySupersonic New Member

    Member Since:
    Oct 7, 2009
    Message Count:
    1
    Country:
    United Kingdom
    DVDX V2 not found error message

    Sorry if this is a bit off subject. I'm having some problems with the N64 emulator. The version is Wii 64 Beta 1.1 'Honey'. I've got the latest version of the homebrew channel up and running (1.0.8) so everything should be fine. When I first installed Wii 64, I burnt a load of games to a DVD-R and the emulator was loading from the disc just fine. However, when I come to run it now and try to load the roms from the DVD, I'm getting an error message saying "DVDX V2 not found". Can anyone help with this? I've tried following some of the previous steps but have had no luck. When I try to run the homebrew installer again, I'm not getting any option to install DVDX. Sorry if I sound like an idiot, I'm a bit new to this stuff! Thanks
    • Member

    qwertymodo New Member

    Member Since:
    Feb 1, 2010
    Message Count:
    763
    Country:
    United States
    That's not entirely true. If you want AHBPROT (which is the same thing as DVDx, without the need of installing anything other than HBC), you need meta.xml and it needs the line above.
    • Member

    PPSainity Blinded by Science

    Member Since:
    Jun 6, 2009
    Message Count:
    646
    Country:
    Canada
    Just a small correction:

    Yes there is no need for DVDx moving forward as the HBC now sets the HW_AHBPROT flag to provide full system access. I specifically say moving forward as programs have to be updated in order to make use of the new access method. Older programs that have not been updated will still need DVDx. Admittedly, these programs are far and few, often being replaced by currently developed homebrew - I'm looking at FTPii specifically here [IMG]

    Back to the original post:

    You can install the last version of DVDx using the older HackMii Installer v0.6 if you can find it. Keep in mind that System Menu 4.3 detects the title ID of this last version of DVDx and promptly deletes it. So if you have SM4.3 you need a program like Priiloader which can apply a [No-Delete HAXX,JODI,DVDX,DISC,DISK,RZDx] patch.

    -[]D
    • Member

    sweenish New Member

    Member Since:
    Apr 16, 2008
    Message Count:
    704
    Location:
    WA
    Country:
    United States
    the original post is working on its third year.

    lots of necro-bumps lately. it's interesting.
    • Member

    PPSainity Blinded by Science

    Member Since:
    Jun 6, 2009
    Message Count:
    646
    Country:
    Canada
    Lol, true. The reply works for BennySupersonic's revival post anyways though...

    -[]D
    • Member

    Arm the Homeless Custom Title

    Member Since:
    May 26, 2008
    Message Count:
    1,762
    Location:
    /home/andy/
    Country:
    United States
    In case you haven't yet noticed, this thread has been bumped from 2008.
    It WAS entirely true back then.
    • Member

    bazamuffin RESIDENT DILF

    Member Since:
    Feb 1, 2009
    Message Count:
    2,036
    Location:
    Shmashmortion Clinic
    Country:
    United Kingdom
    • Member

    OGTiago New Member

    Member Since:
    Nov 21, 2006
    Message Count:
    235
    Location:
    London, England Rank: Temp God
    Country:
    Portugal
    People don't want to create new threads to be told to search. So when you do search you get some very old dead threads, which then get bumped.
    • Member

    sweenish New Member

    Member Since:
    Apr 16, 2008
    Message Count:
    704
    Location:
    WA
    Country:
    United States
    i know why it's happening, it just typically doesn't happen here.

    looks like that whole netiquette thing is starting to catch on a tad.
  1. Skaendo
    This message by Skaendo has been removed from public view by Sicklyboy, Sep 13, 2014 at 3:28 AM, Reason: Bumping 3 year old thread for the sake of bumping it.
    Sep 13, 2014 at 3:22 AM

SPONSORED LINKS
 
Thread Status:
Not open for further replies.

Share This Page