Help: Upgrading R4i Gold 3DS (www.r4ids.cn)

Discussion in 'NDS - Flashcarts and Accessories' started by Phisher, Dec 19, 2012.

Dec 19, 2012
    • Newcomer

    Phisher New Member

    Member Since:
    Dec 19, 2012
    Message Count:
    3
    Country:
    Philippines
    Hello guys,

    I would like to ask something out of my curiosity and being new to R4 flash carts. I have bought an R4i Gold 3DS card from www.r4ids.cn and it works good on my NDSi XL v1.41U with the WOODR4 v1.54. However, I also have another NDSi XL which has different firmware having 1.44U. The flash cart doesnt work on the new firmware that my other NDSi XL has (1.44U). I have checked the website and check the upgrade patch section for flash carts. But before I would like to try patching my R4i Gold 3DS flash cart to 1.44U in order to make it work on my second NDSi XL (1.44U), I would first like to know if I could still possibly play it on my first NDSi XL (1.41U). Has anyone have experience the same kind of situation as of me having 2 NDSi each has different firmware. In addition, I don't want to upgrade the first NDSi XL (1.41U) because I want to make sure first that it will work on the latest one so I needed the old firmware one for back up just in case. So in short, if I update patch my flash cart to 1.44U, can I still used it on my NDSi XL 1.41U at the same time?

    Looking forward for any help.
    • Member

    jurassicplayer Nyahahahahaha~

    Member Since:
    Mar 7, 2009
    Message Count:
    4,002
    Location:
    Pantsuland
    Country:
    United States
    Generally flashcart firmware updates are able to support latest and below...but I faintly recall someone once saying that they couldn't get a flashcart working on an older DSi firmware, though it worked on a newer one. I have no idea about if it is true or whether it was the r4ids.cn flashcart.
    • Newcomer

    Phisher New Member

    Member Since:
    Dec 19, 2012
    Message Count:
    3
    Country:
    Philippines
    Thank you. That's a very quick response :)

    I also googled this little problem of mine but I didn't get straight answers. BTW, I also have read something like "The old flash cart may not run or not be compatible to newer DSi firmware because you need to update the flash cart to be able to run on newer firmware". But I haven't read that when you upgraded the flash cart, it will still can be run on older DSi firmware.
    • Member

    porkiewpyne Report-er

    Member Since:
    Jun 8, 2008
    Message Count:
    1,659
    Country:
    Australia
    As jurassicplayer pointed out, you shouldn't have any problems, at least not with the DSiXL afaik. I vaguely remember hearing complaints about the latest fix not working for a 3DS on the earliest firmware but cases like those are few and far between.
    • Newcomer

    Phisher New Member

    Member Since:
    Dec 19, 2012
    Message Count:
    3
    Country:
    Philippines
    Hello again, I was trying to update my NDSi now at 1.41 but I saw that the latest firmware was 1.45. It's my first time to update my NDSi, can I select which firmware I will update like from 1.41 to 1.44 first? How can this be done? Please anyone?

Share This Page