[HELP] Questions about vWii and USB Loader GX

Discussion in 'Wii U - Hacking & Backup Loaders' started by mja7011, Aug 30, 2017.

  1. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,572
    8,919
    Oct 27, 2002
    France
    Engine room, learning
    I suspect you placed the game in incorrect folder, or using incorrect filename or foldername. that's what happen when users are doing it manually instead of using WiiBackupManager.

    I suspect you didn't follow a softmod guide to install custom IOS to play Wii games from USB.
    "Running on IOS 58. Wii disc based games and some channels will not work". Of course that's the reason Wii games don't work, it's warning you at loader's launch that wii games will not work because it's running on IOS58!

    maybe this thread will interest you, the user had the same problem, and I gave all the solutions :
    https://gbatemp.net/threads/almost-total-noobie-questions-about-usb-loader-gx.483759/#post-7571612
     
    Last edited by Cyan, Sep 13, 2017
  2. mja7011
    OP

    mja7011 Member

    Newcomer
    48
    2
    Sep 14, 2009
    United States
    Ok I shall try this method this weekend when I get back home, thanks!
     
  3. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,572
    8,919
    Oct 27, 2002
    France
    Engine room, learning
    just a thing, the link I gave in the other thread is for Wii, not WiiU.
    you'll need this one instead : d2x cIOS installer full pack for vWii
    and install d2x v10 r52 instead of v8 final.

    but you can still read the other thread, it may contains interesting information.
     
  4. mja7011
    OP

    mja7011 Member

    Newcomer
    48
    2
    Sep 14, 2009
    United States
    Alright, I downloaded cIOS with these settings using your link

    What: d2x v10 r52
    where : 249
    base : 57

    However, now when I load up USB Loader GX, it cannot detect my USB and after the 20 second countdown, USB Loader GX only shows the programs on my vWii, not USB. hmm.....
     
  5. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,572
    8,919
    Oct 27, 2002
    France
    Engine room, learning
    again, that's normal. it means it's now working (sort of).
    it means it's now correctly using the slot249 to loads, which is not compatible with your HDD. you need to set the loader to boot with IOS58 but play with IOS249.
    for a strange reason, a lot of newer HDD are not initializing with cIOS.

    in USBLoaderGX, go to settings > loader's settings >
    set the "loader's IOS" to 58

    reboot the loader, it should now "init the drive" with 58, and "play the game" with 249
     
  6. mja7011
    OP

    mja7011 Member

    Newcomer
    48
    2
    Sep 14, 2009
    United States
    Ok, I changed "loader IOS" to 58 and now it can read the USB.

    However, the same thing still happens when I try to play Wii or gamecube games, it goes back to the homebrew channel or Health and Safety Screen.

    edit: Or should I set it to IOS 57 since my base was 57?
     
    Last edited by mja7011, Sep 16, 2017
  7. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,572
    8,919
    Oct 27, 2002
    France
    Engine room, learning
    hmm, gamecube game should work if you properly told USBLoaderGX to launch nintendont.
    by default, it's set to launch disc and MIOS.
    you have to go to settings > loader's settings > gamecube mode : Nintendont

    You also need nintendont in /apps/nintendont/boot.dol
    and don't use latest release (it's broken, use 4.451 for the moment).


    About wii games, be sure you have only one HDD plugged, you have HDD in USB Port 0, you have game's IOS to correct slot number in the settings, you have cIOS correctly installed in that slot.
    everything is important, all you do is important.
    doing things randomly will just not work.
    I really don't understand why so many users have issues doing it. it's so easy : install hbc, install cIOS, plug hdd in port0, optionaly set IOS to 58. set gamecube mode to desired mode (usually nintendont). done. all works fine now.
     
    Last edited by Cyan, Sep 16, 2017
  8. mja7011
    OP

    mja7011 Member

    Newcomer
    48
    2
    Sep 14, 2009
    United States
    Gamecube Mode is set to Nintendont

    I have Nintendont ver. 4.451

    I have USB Loader GX ver. 3.0 r1262

    I'm using cIOS in these settings
    What: d2x v10 r52
    Where : 249
    Base : 57

    I have Loader's IOS set to IOS 58 and I have Game's IOS set to IOS 249

    The HDD is plugged into port 0 (using Y usb cable)

    Is there something I'm missing?
     
    Last edited by mja7011, Sep 16, 2017
  9. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,572
    8,919
    Oct 27, 2002
    France
    Engine room, learning
    no, everything looks fine.
    at worse, your drive is not compatible at all with cIOS (so, no wii games), but it should work with nintendont as it uses IOS58 too.

    so I don't know why it doesn't work for both game type.
     
  10. mja7011
    OP

    mja7011 Member

    Newcomer
    48
    2
    Sep 14, 2009
    United States
    edit: Wow, I finally figured it out... at least the Wii portion of it.

    I think the problem is that the partition that the wii and gamecube games are on was not the primary partition on the HDD so I had to change that using Easeus. I am now able to play wii games and I was successfully able to install all my previous game saves... except for SSBB, it freezes for some reason.
     
    Last edited by mja7011, Sep 18, 2017