Official hakchi2 - NES Mini very simple pimp tool

Discussion in 'Other Consoles & Oldies' started by Cluster, Jan 7, 2017.

  1. Maurobr76

    Maurobr76 Advanced Member

    Newcomer
    88
    13
    Feb 13, 2017
    Im happy with the old hakchi 20.15 with retroarch from a few days ago...

    But...

    Will i gain anything if i instal newest retroarch? But keep My hakchi as it is.
     


  2. PPlays

    PPlays GBAtemp Fan

    Member
    327
    112
    Oct 5, 2017
    United States
    There should be another size option a couple lines below the aspect ratio one.

    — Posts automatically merged - Please don't double post! —

    Better compatibility, some nice new bells and whistles.
     
    Last edited by PPlays, Oct 12, 2017
    Maurobr76 likes this.
  3. Kumoashi

    Kumoashi GBAtemp Regular

    Member
    178
    55
    Mar 8, 2016
    United States
    The original 21 games have always been in the read only area of the system.
    Older versions of Hakchi2 were not able to access the games directly from there, so a copy would be added to the re-writable section, which would waste space that could be used by other games.
    The new version now simply links to where the games are originally stored. So it has never been possible to change, replace, or mod, the original games directly, we have always needed to hide them, and then add a the new modded version.
     
    Baggins likes this.
  4. RevRaven

    RevRaven Member

    Newcomer
    10
    5
    Oct 11, 2017
    United States
    I can confirm that Robin64's Illusion of Gaia patch works on Canoe. Spreadsheet updated with the link to the patch. Hakchi 2.21c will say it's incompatible when adding, but it will load into the program (and SNESC) with no problem.
     
    Last edited by RevRaven, Oct 12, 2017
    Pikapichu and the_randomizer like this.
  5. Kumoashi

    Kumoashi GBAtemp Regular

    Member
    178
    55
    Mar 8, 2016
    United States
    Then what "version" should they use? Do you mean they should use an older version? If not, then you are only confusing people, because Cluster only has 2 ways to get Hakchi2.
    1. Download the Portable Version, which is a self contained version that can be extracted and ran from any drive or folder on your computer.
    2. Download the Web Installer Version, which installs it's self to the C drive and will auto-update it's self whenever a new version comes out.

    As far as using an older version VS a newer version, I for one am using the newest release, version 2.21c A.K.A. 2.0.21.42, and I have had no problems at all. It installs and runs just as good, if not better, then the older versions. Maybe people that are having problems are not doing something right?
     
  6. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    22,090
    10,425
    Apr 29, 2011
    United States
    Dr. Wahwee's castle
    I'm not the one having issues flashing the kernel.
     
  7. Kumoashi

    Kumoashi GBAtemp Regular

    Member
    178
    55
    Mar 8, 2016
    United States
    I wasn't saying you were. Sorry if it sounded that way. I was just commenting on how you said that you don't use the Web Installer and you don't use the Portable version. You also told the other person not to use either one as well. You may have typed it wrong for all I know, but I didn't mean anything negative by what I was saying. I just want to help stop some of the confusion that people are having on this thread.
     
  8. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    22,090
    10,425
    Apr 29, 2011
    United States
    Dr. Wahwee's castle
    I did type it wrong. Portable version works better.
     
    Kumoashi likes this.
  9. Kumoashi

    Kumoashi GBAtemp Regular

    Member
    178
    55
    Mar 8, 2016
    United States
    I personally prefer the Web Installer, but whatever works for you is still fine. :)
     
  10. Liriel

    Liriel GBAtemp Regular

    Member
    290
    75
    Sep 26, 2017
    Germany
    thats new and come with the borders and with 1.0 retroarch from cluster
     
  11. Baggins

    Baggins GBAtemp Regular

    Member
    215
    58
    Jan 27, 2017
    United States
    Flashign the kernel was fine... It has a shell error when trying to add games. There have been around 4-5 people so far that have the problem and its always on the EU systems.

    — Posts automatically merged - Please don't double post! —

    To be honest the program itself is fool proof... by that I mean a monkey could figure it out... It gives you straight tforward intructions, and ten tells you when and what buttons to push... and warns you if you if need to install something first. LIke the 'driver'.

    I can't control what it does after that, when it starts trying to copy over roms... and then crashes at the end....
     
  12. josete2k

    josete2k GBAtemp Regular

    Member
    201
    8
    Apr 24, 2009
    As I've seen... The aspect ratio needs to be set at 5:4 but the vertical size is still a little larger.

    Maybe a custom resolution...
     
  13. Baggins

    Baggins GBAtemp Regular

    Member
    215
    58
    Jan 27, 2017
    United States
    I don't know why people keep mocking you and anyone else with this problem, instead of trying to be helpful and figure out what might be causing the problem in the first place...

    It really is rather rude....
     
  14. Liriel

    Liriel GBAtemp Regular

    Member
    290
    75
    Sep 26, 2017
    Germany
    strange no errors with my eu mini snes and flashing
     
    Last edited by Liriel, Oct 12, 2017
  15. mattmanforever

    mattmanforever Newbie

    Newcomer
    6
    0
    Oct 8, 2017
    United States
    So what I did was go to Retroarch menu, options, disable crop overscan. And then I went to settings, video, and set every game to the "core" aspect ratio. That fixes Castlevania. Only game that looked weird was Battletoads, which has a black bar on the left side... but that's an issue with the game.
     
  16. Kumoashi

    Kumoashi GBAtemp Regular

    Member
    178
    55
    Mar 8, 2016
    United States
    How do you make it so that your name is visible when you're editing the compatibility list (or any other Google Docs page)? I'm logged in, but it shows me as anonymous, and I can't seem to be able to find the setting to change that.
     
  17. Baggins

    Baggins GBAtemp Regular

    Member
    215
    58
    Jan 27, 2017
    United States
    Right, whatever it is not effecting everyone. So it makes it harder to tell what is causing it... Slightly different models of UK systems out in the wild (from different sources)? Differences in computer hardware causing issues? .... cross contamination form previous hacked NES backups in the same files? (one person seems to think it works if they keep files form the NES and SNES in separate folders, rather than sharing the same HACKCHI folder). Who knows...?

    It's weird enough that there seems to be people having success with games running on the mini, that others say 'doesn't work'.... SO there maybe many factors people aren't figuring into the equation.
     
  18. mattmanforever

    mattmanforever Newbie

    Newcomer
    6
    0
    Oct 8, 2017
    United States
    Hopefully fixed in the next version.
     
  19. Sappoide

    Sappoide Advanced Member

    Member
    61
    2
    May 7, 2008
    Italy
    Behind you
    Hi guys, I'm currently using Hakchi 2.20 and I'd like to update to the newest version.

    Should I reflash the original kernel and delete all the games\cores added before updating? Thanks :)
     
  20. PPlays

    PPlays GBAtemp Fan

    Member
    327
    112
    Oct 5, 2017
    United States
    I would recommend that. There are different directories the new version writes to as opposed to the old version that could be causing people some errors. If you know what folder to put your original dump in though you can do that instead of reflashing it.
     
    Hackcell and Sappoide like this.