Guide to: Converting PS1 games for PSP

Discussion in 'PSP - Hacking & Homebrew' started by Jamstruth, Jan 28, 2010.

Jan 28, 2010
    • Newcomer

    Truner New Member

    Member Since:
    May 26, 2011
    Message Count:
    86
    Location:
    Budapest
    Country:
    Hungary
    Yet again, I'm in need of help from you guys.
    I have my little devil right here, the oldest model. I've got 6.60 Pro B10 installed on it, permanent version.
    I just installed popsloader using the installer (almost 700 MB, installed everything I would ever need). With this, I am able to switch the versions just fine. Now to the meat of the problem. The latest Tales of Phantasia english patch has ben released. Instead of ripping my disc, I decided to get myself a redump copy of the game. I'm pretty sure the one doing that one had a better condition disc than what I have. Patched the game just fine. It runs perfectly on ePSXe. I converted it with PSX2PSP 1.4.2. Since I keep my stuff organized, I added a theme too:

    [IMG]

    I've been converting the game with various compression levels (used 0, 4, 8 and 9 so far) but the game refuses to run. Before installing popsloader, it would just go to a black screen. Now when I change pops, it'll turn off. What am I doing wrong?


    • Member

    xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Member Since:
    Jul 14, 2008
    Message Count:
    5,861
    Country:
    United Kingdom
    That's a sign you've got something wrong with your poploader setup. Either the wrong popsloader prx or some other contradiction causing the PSP to spaz out.
    • Newcomer

    Truner New Member

    Member Since:
    May 26, 2011
    Message Count:
    86
    Location:
    Budapest
    Country:
    Hungary
    I also have pspetext plugin turned on... I remember using it with Spyro the Dragon (it worked), so I'm not sure if that's the problem.
    I'm also using the original ToP ID. But I've heard that it should work with it. I've set the pops to 3.71 and 3.72 (the ones confirmed to be working with ToP).

    What exactly can I do? This is my first time using popsloader, but I used this guide: http://gbatemp.net/threads/guide-to-installing-popsloader-v3-on-pro-b8-through-pro-c-cfw.301579/
    and followed everything stated inside it.
    • Member

    xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Member Since:
    Jul 14, 2008
    Message Count:
    5,861
    Country:
    United Kingdom
    Disable pspetext then and see if it works? (also why that plugin over something like CWCheat?)

    The only time i experienced the problem you're explaining is when i forgot to update my popsloader from the 3.71 variety to 5.xx when i updated. That too caused the PSP to shutdown....switching the popsloader plugin to one suited to my firmware fixed it.
    • Newcomer

    Truner New Member

    Member Since:
    May 26, 2011
    Message Count:
    86
    Location:
    Budapest
    Country:
    Hungary
    Disabled the plugin, changed to popsloader 5.50. Still experienced shut down. Should I try each and every version and see if they work?
    • Member

    xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Member Since:
    Jul 14, 2008
    Message Count:
    5,861
    Country:
    United Kingdom
    I don't mean the pops you're selecting...i'll assume if you followed the guide the prx's are ok. Try getting a different popsloader.prx/popscore.prx setup.
    • Newcomer

    Truner New Member

    Member Since:
    May 26, 2011
    Message Count:
    86
    Location:
    Budapest
    Country:
    Hungary
    That means downloading from a different website? Are there any confirmed-to-be-working variants that you know of?

    EDIT:
    Downloaded this: http://dl.qj.net/psp/homebrew-applications/popsloader-v4d.html

    and pasted the two prx files from the dist folder to my seplugin folder. Now it works! Thank you for your help, I am now one happy fan! :)
    Last edited by Truner, Jan 5, 2013. Reason: Solution found
    • Newcomer

    Truner New Member

    Member Since:
    May 26, 2011
    Message Count:
    86
    Location:
    Budapest
    Country:
    Hungary
    EDIT: delete, didn't see the really small edit text at first.
    • Newcomer

    SalvadorOliveira New Member

    Member Since:
    Mar 31, 2012
    Message Count:
    30
    using Pops 5.50 and my OS is 5.50 GEN-03.
    set the POP to 4.01 (because that's what the compatibility list says for Azure Dreams)
    I can't load anything past the PS1 preloader screen, and now I don't get the options anymore when I hold down R.

    what am I doing wrong here?

    EDIT: FF Tactics + Rebirth Mod seems to work fine...what am I missing to get Azure Dreams working?
    Last edited by SalvadorOliveira, Jan 6, 2013
    • Newcomer

    Truner New Member

    Member Since:
    May 26, 2011
    Message Count:
    86
    Location:
    Budapest
    Country:
    Hungary
    Try what I did. Follow the guide I linked to up there, change out the popsloader files from the 4D version and try holding down R before you start the game.
    If you get the pops menu, try out different pops versions or search google for "Azure Dreams Popsloader" or something. There might just be another forum where people share their experiences. At least that's what I did to figure out which pops runs Tales of Phantasia the best.

    EDIT: when converting, try to use different compression rates. Maybe Azure Dreams can't handle Level 9 (best). I heard that usually causes games to not run. Also check the iso you are converting, as it might be a bad dump! Happened to me before.
    Last edited by Truner, Jan 6, 2013. Reason: Additional help
    • Newcomer

    SalvadorOliveira New Member

    Member Since:
    Mar 31, 2012
    Message Count:
    30
    I checked the compatibility list - it said 4.01, so I went 4.01. after setting to 4.01, holding R won't let me change the version anymore, so I can't change it.

    also; I tried 9 and 7...I may try 5 as well...there's no downside to a compression rate of 1, besides less space, right?
    • Newcomer

    Senbei Norimaki New Member

    Member Since:
    Dec 10, 2012
    Message Count:
    87
    Country:
    Pacific Ocean
    I tried to convert a Dr Slump PSX.cue file to PSP and the game boots up ,but it always freezes at the Bandai screen. Am I doing something wrong.
    • Member

    xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Member Since:
    Jul 14, 2008
    Message Count:
    5,861
    Country:
    United Kingdom
    Sure sign you need to use popsloader to adjust your pops version and increase compatibility.
    • Newcomer

    RyanHwang New Member

    Member Since:
    Feb 23, 2013
    Message Count:
    11
    Country:
    Korea, South
    FYI most games are working properly, but few games are not.
    • Newcomer

    puding New Member

    Member Since:
    Feb 24, 2013
    Message Count:
    16
    Country:
    Brazil
    • Member

    xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Member Since:
    Jul 14, 2008
    Message Count:
    5,861
    Country:
    United Kingdom
    It may not be loading because you're not using the right pops version for compatibility.

    The base.pbp (and keys.bin) files you need are from the Hot Shots Golf 2 PSN game. Grab the Hot Shots Golf 2 official Sony EBOOT.pbp, rename it to BASE.pbp You need the keys.bin you got when you activated the game too. Although obviously i'm sure you'll think of something....

    Popstation supports BIN,IMG and ISO. Usually i use Alcohol 52% to rip to ISO or BIN. Conversion between formats may break things.
    puding likes this.
    • Newcomer

    puding New Member

    Member Since:
    Feb 24, 2013
    Message Count:
    16
    Country:
    Brazil
    Thanks. Converting this game with popstation will not work? I really need the official release?
    • Member

    xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Member Since:
    Jul 14, 2008
    Message Count:
    5,861
    Country:
    United Kingdom
    What game?

    Popstation should work fine although you still may need posploader....you just need to somehow find the base.pbp and keys.bin files. Now If only there were some massive internet search engine....
    • Newcomer

    puding New Member

    Member Since:
    Feb 24, 2013
    Message Count:
    16
    Country:
    Brazil
    Hot Shots Golf 2. You said I need the EBOOT, so I just need to convert this game?
    • Member

    xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Member Since:
    Jul 14, 2008
    Message Count:
    5,861
    Country:
    United Kingdom
    OK, ignore everything i said about Hot Shots Golf 2 because it'll just confuse you. You just need the base.pbp and keys.bin files required for PSX eboot conversion....a few minutes of trial and error should avail you of those.

    What game are you trying to convert?

SPONSORED LINKS
 

Share This Page