Question Fiddler Not Working on 3.0

Discussion in 'Switch - Hacking & Homebrew' started by 00Cancer, Jul 12, 2017.

  1. 00Cancer
    OP

    00Cancer Newbie

    Newcomer
    4
    0
    Feb 1, 2017
    United States
    Edit: Never mind, I am just an idiot. I forgot to check "enable rules" and "unmatched requests passthrough" on the AutoResponder tab so it wasn't doing anything. Now it works perfectly.

    If this has already been solved, please just reply with a link to the thread.

    So I have setup fiddler and I am almost 95% sure that I setup it up right, but low and behold it doesn't work. I have changed the google redirect in fiddler from http://conntest.nintendowifi.net/ to http://ctest.cdn.nintendo.net/ but it didn't do anything different. Instead of getting the registration error that should happen, the internet connects correctly and it doesn't redirect me to google.

    Here is a screenshot of the fiddler rules: https://gyazo.com/b63af5e58e21e06caa1d6b03cf64b071
     
    Last edited by 00Cancer, Jul 12, 2017
  2. 00Cancer
    OP

    00Cancer Newbie

    Newcomer
    4
    0
    Feb 1, 2017
    United States
    BTW: My computer which is running fiddler is connected to ethernet.
     
  3. thedetire

    thedetire Member

    Newcomer
    18
    14
    Apr 20, 2012
    Netherlands
    I've never actually went browsing, but did use Fiddler once for blocking updates so i may be able to help you.

    First things first, did you change your Switch wifi settings to be connected to your pc?
    (Wifi -> Proxy = PC IP & Port = 8.8.8.8 )
    And make sure the requests from the switch are actually popping up on your Fiddler. The requests may be different than your settings (https instead of http etc.)
    Are those drops actually needed?

    You can also just put a custom DNS (045.055.142.122)
    See this thread

    That's all.
     
  4. 00Cancer
    OP

    00Cancer Newbie

    Newcomer
    4
    0
    Feb 1, 2017
    United States
    I figured it out. Read the edit.