FFXV required firmware

Discussion in 'PS4 - Games & Content' started by cathor, Dec 1, 2016.

  1. cathor
    OP

    cathor Member

    Newcomer
    24
    17
    Oct 15, 2016
    Hi,

    Which firmware is required to play FFXV? I am on 3.55 and thinking about buying it.

    Cheers.
     
  2. Sonic Angel Knight

    Sonic Angel Knight GBAtemp Guru

    Member
    8,674
    4,128
    May 27, 2016
    United States
    New York
    Aren't you buying the game cause you want to play it, or are you deciding against it cause it may require a update?:mellow:
     
  3. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,027
    3,340
    Nov 13, 2014
    United States
    obviously he does not want the exploit to get patched
     
  4. cathor
    OP

    cathor Member

    Newcomer
    24
    17
    Oct 15, 2016
    Yes, would prefer to to stay on 3.55. Or below 4.05 at least.
     
  5. Sonic Angel Knight

    Sonic Angel Knight GBAtemp Guru

    Member
    8,674
    4,128
    May 27, 2016
    United States
    New York
    It wasn't obvious to me. Maybe he didn't know that updates are in game disc so when buying them it installs which ever update needed to play on the system. Is why i asked the reason for the question.:mellow:
     
  6. cathor
    OP

    cathor Member

    Newcomer
    24
    17
    Oct 15, 2016
    Got myself a copy, the answer to my question is; 4.0... If anyone is interested...
     
  7. MadCabbit

    MadCabbit Member

    Newcomer
    11
    0
    Nov 25, 2008
    United States
    So the game won't let you do anything below that in order to get the update? I was wondering if something like PSProxy might get around that.
     
  8. Sick Wario

    Sick Wario Club Nintendo

    Member
    1,225
    62
    Jul 24, 2006
    NNID: godrugal
    i suggest NOT playing until you get the 10GB day 1 patch.
    friend and i got the game, ignored the patch download and waited through the 30min 'installing' tutorial.
    well it seemed great but after only 2hrs play yesterday the game crashed and locked up the ps4, only option pulling the power. more worryingly the ps4 went into recovery mode after rebooting. no error code in system. never seen this happen before with 15+ games. launch ps4 latest fw
     
  9. MadCabbit

    MadCabbit Member

    Newcomer
    11
    0
    Nov 25, 2008
    United States
    Just to be clear from what I'm reading here, the PS4 needs to be at least on FW 4.0 to even run the game, but to get the day one update to make it truly playable, there's no other way around at least upgrading to 4.6 or 4.5 with psproxy to get the updates?
     
  10. MadCabbit

    MadCabbit Member

    Newcomer
    11
    0
    Nov 25, 2008
    United States
    I ended up updating to 4.05 and managed to get the 1.02 update installed a few weeks back. I managed to use PSProxy and SKFU Pr0xy to at least download the 1.03 update, but it appears to require either 4.06 or 4.07 and refuses to update the game without updating the firmware. Even with PSProxy on, it tells me the system software needs to be update, but if I click update now, it says I have the newest version. I'm guessing Sony will only be pushing 1.03+ directly from now on, so no more updating the game at all even from 1.0 without updating the system past 4.05.
     
    Last edited by MadCabbit, Dec 29, 2016