Cluster releases Hakchi2 v.2.20, adding support for SNES Classic.

Discussion in 'Other Consoles & Oldies' started by sks316, Oct 8, 2017.

  1. erolz

    erolz GBAtemp Fan

    Member
    464
    13
    Jul 22, 2008
    Belgium
    Anyone here got Street Fighter Alpha 2 running on the SNESC? I read you have to apply the "S-DD1 patch" but can not figure out where to find this...
     


  2. leon315

    leon315 POWERLIFTER

    Member
    532
    298
    Nov 27, 2013
    Italy
    if snes mini has a rasperry and it's able to handle Retroarch, technically can it run CPS1/2/3/4 ROMS???
     
  3. AyanamiRei

    AyanamiRei GBAtemp Fan

    Member
    380
    64
    Sep 24, 2015
    France
    OH great, I asked the supermarket to sell mine to someone else. -_- (I thought it wouldn't be possible after all)

    Still, the other reason of my cancellation was that it actually looks not really good (euphemism) on a flat computer monitor and there is no way to plug it on a regular cathodic screen.
     
    Last edited by AyanamiRei, Oct 13, 2017 at 7:53 PM
  4. Mafia

    Mafia Member

    Newcomer
    20
    5
    Oct 1, 2017
    Seychelles
    Works here for me. Tested it out this morning. Just uploaded rom. Not sure if it had to be patch or not. Didn't pay attention but runs with snes borders too.
     
  5. cybrian

    cybrian Advanced Member

    Newcomer
    83
    47
    Sep 14, 2009
    United States
    My SNES Mini broke when I stuck raspberries inside it
     
  6. Mafia

    Mafia Member

    Newcomer
    20
    5
    Oct 1, 2017
    Seychelles
    Hakchi 2.21c has this feature
    • Scripts autoupdate, so you don't need to reflash custrom kernel after every update.
    Does anyone know how this will work?
     
  7. nick10101

    nick10101 Newbie

    Newcomer
    4
    0
    Aug 22, 2017
    United States
    does anybody know if these games work, or ever will with updates to hakchi.

    Illusion of gaia
    secret of evermore
    star ocean
    tales of phantasia
    treasures of rudras
    bahamut lagoon
    romancing saga 3
    thanks

    ps. sorry if this has been asked before, i know star ocean will not work, but was wondering if updates to hakchi will fix this?
     
  8. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    22,048
    10,357
    Apr 29, 2011
    United States
    Dr. Wahwee's castle
    Romancing Saga, Treasure of the Rudras and Bahamut Lagoon all run fine*
    https://docs.google.com/spreadsheet...8t2aV5cVswYlnsdKxn9xoIW2Y/edit#gid=2014317767

    Only thing is two of three games use pseudo hi-res for text, and may look a bit blurry, but it's nonissue.
     
  9. 1alien1

    1alien1 Member

    Newcomer
    43
    0
    Aug 26, 2013
    Gambia, The
    is there any way yet, to run terranigma eu version without problems?
     
  10. nick10101

    nick10101 Newbie

    Newcomer
    4
    0
    Aug 22, 2017
    United States
    thanks randomizer.

    Do the other run fine with retroarch 1.0?
    aka.
    Illusion of gaia
    secret of evermore
    star ocean
    tales of phantasia
     
  11. loon111

    loon111 Member

    Newcomer
    40
    2
    Feb 4, 2007
    Hi i have asked this before here an no reply, does anyone know why i cant upload the games through parralells but can dump an flash the firmware at all?

    Any help would be much appreciated

    Thanks
     
  12. Mafia

    Mafia Member

    Newcomer
    20
    5
    Oct 1, 2017
    Seychelles
    So there's a newer hakchi2.21D out. I have 2.21C so how does it auto update? I'm a bit confused ‍♀️
     
  13. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    22,048
    10,357
    Apr 29, 2011
    United States
    Dr. Wahwee's castle
    Those other games, yes, they should work on RA.
     
  14. nick10101

    nick10101 Newbie

    Newcomer
    4
    0
    Aug 22, 2017
    United States
    thanks. one last question regarding retroarch.

    If doing this, will the settings in the snes still allow me to switch aspect ratios? Like full screen, 4:3 and pixel perfect. thanks
     
  15. LordVash

    LordVash Newbie

    Newcomer
    5
    0
    Oct 4, 2017
    Italy
    if i'm using the 2.20 what should i do for using a newer version? Kernel --> Uninstall?
    In that case i will lose all the games that i've already put inside the SNES MINI? (i'm using the zip version not the web one)
    Thanks in advance
     
  16. CaptainZef

    CaptainZef GBAtemp Regular

    Member
    110
    10
    Sep 14, 2009
    Canada
    does anyone know why it's spitting out a c7 error with an english patched ROM even though i'm using retroarch? other english patched roms work too, so i'm extra confused
     
  17. Home_Rowed

    Home_Rowed GBAtemp Regular

    Member
    103
    18
    Oct 17, 2006
    United States
    I also want to know if this is possible.
     
  18. Jacklack3

    Jacklack3 ( ゚ヮ゚) buddie was here

    Member
    1,518
    1,955
    Oct 6, 2015
    Canada
    In your basement Dick Size: 5 meters.
    (i know this is over and done with but) maybe you should've have "nintendo outraged" /s
     
  19. spyder918

    spyder918 Member

    Newcomer
    29
    0
    Sep 7, 2017
    United States
     
  20. TheRenegadist

    TheRenegadist Member

    Newcomer
    44
    7
    May 19, 2017
    United States
    Ladies and gents, now imagine Hakchi2 with the N64 classic. NOW you're playing with power!