cIOSX rev21d2x: Yet Another Hot Fix!!!!

Discussion in 'Wii - Hacking' started by davebaol, Feb 3, 2011.

?

Did d2x work for you?

  1. Yes, I had an issue with the official cios and d2x fixed it

    85 vote(s)
    48.0%
  2. Yes, but everything was already working for me with the official cios

    75 vote(s)
    42.4%
  3. No, and I posted what goes wrong

    8 vote(s)
    4.5%
  4. No, and I won't report what goes wrong because I am a troll

    9 vote(s)
    5.1%
Feb 3, 2011
  1. Etheboss

    Member Etheboss Official LULWUT supporter

    Joined:
    Feb 24, 2009
    Messages:
    2,444
    Location:
    Around somewhere
    Country:
    Netherlands
    In Wiiflow IRC, reason mainly busy in real life.
     
    MassiveRican likes this.


  2. d.d.d.

    Member d.d.d. GBAtemp Fan

    Joined:
    Jun 26, 2012
    Messages:
    430
    Location:
    Tokyo Metropolis
    Country:
    Japan
    I know that all too well. Good luck to him~
     
    MassiveRican likes this.
  3. Noobwboob

    Newcomer Noobwboob Newbie

    Joined:
    Nov 15, 2013
    Messages:
    1
    Country:
    Canada
    Sorry, extreme newbie here but I am having the exact same problem with the TMD versions being one point off.... I also had a previously Modded Wii but someone else did the mod so I have no idea the settings that may have been involved.... The old mod was gashed when my Dad unwittingly did an update from a commercial Donkey Kong game that someone purchased for my son... This wiped out the home brew channel but the backup launcher still shows up in the menu channels: I wonder if this has something to do with it? Residual old mod stuff? I know absolutely nothing about this and am on a super huge learning curve trying to get this set up again. Any ideas or suggestions in plain English for a learner would be greatly appreciated. Thanks for your patience.
     
  4. Maxternal

    Member Maxternal Peanut Gallery Spokesman

    Joined:
    Nov 15, 2011
    Messages:
    5,210
    Location:
    Deep in GBAtemp addiction
    Country:
    Costa Rica
    Run ModMii on your computer and answer questions and make the selections as if you had never had your Wii modded before. I'll automatically download and build everything you need to overwrite your current, broken softmod with a fully working one and generate a very simple to follow step by step guide of what to do with it all. (it will also include parts of the softmod you were missing before that will now block any such updates so grandpa won't accidentally break it again.)
     
  5. norbyte

    Newcomer norbyte Advanced Member

    Joined:
    May 28, 2011
    Messages:
    55
    Country:
    Germany
    Is there any chance to install d2x v10 with base 37 on vwii to run singing games? Unfortunately base 57 doesn't work with Let's Sing and other games. :(
     
  6. Magnus87

    Member Magnus87 GBAtemp Regular

    Joined:
    Apr 28, 2013
    Messages:
    172
    Country:
    Argentina



    Unfortunately most of the projects are dead (CIOS / cMIOS, emulators, homebrew). Only loaders receive updates but becoming less frequent
     
  7. jayglass
    This message by jayglass has been removed from public view by Cyan, Jun 26, 2014, Reason: spamming the same question everywhere.
    Jun 26, 2014
  8. maverickbleh

    Newcomer maverickbleh Newbie

    Joined:
    Feb 4, 2010
    Messages:
    8
    Country:
    United States
    I try to install v10 on vWii, but when I start the installer, it only offers v4, v5 or v6. the ciosmaps.xml is in the d2x installer folder, and there's also the v10 folder.

    What could be the problem?

    Thank you!
     
  9. Cyan

    Global Moderator Cyan GBATemp's lurking knight

    Joined:
    Oct 27, 2002
    Messages:
    17,012
    Location:
    Engine room, learning
    Country:
    France
    It could be incorrect install of the files, or copied in the wrong place.


    Here is a package ready to use with both v10 and v10-alt for vWii.
    be sure to not install v6 and older on vWii or it will brick it.
    WiiU's vWii works only with vWii cIOS v10 and v10-alt
    d2x-cios-installer-2.2mod by FIX94 - v10-beta52 v10-beta53alt For vWi only.zip

    I'll also post here for users interested in the Wii full pack:
    d2x-cios-installer-3.1 v4 v5 v6 v7 v8 v10 v10-alt For Wii only


    Don't install Wii IOS on vWii, and don't install vWii IOS on Wii!
     
  10. maverickbleh

    Newcomer maverickbleh Newbie

    Joined:
    Feb 4, 2010
    Messages:
    8
    Country:
    United States

    Thank you very much for your quick answer, I'll look it up when I get home tonight!
     
  11. killerkalmah

    Newcomer killerkalmah Member

    Joined:
    Sep 3, 2014
    Messages:
    22
    Location:
    Hell's Kitchen
    Country:
    United States
    Is there any list or recomended d2x cios to install for better functionality? or It's ok to install them all? (Im very lost) My Wii is 4.3U. I will appretiate some help here
     
  12. Etheboss

    Member Etheboss Official LULWUT supporter

    Joined:
    Feb 24, 2009
    Messages:
    2,444
    Location:
    Around somewhere
    Country:
    Netherlands
  13. killerkalmah

    Newcomer killerkalmah Member

    Joined:
    Sep 3, 2014
    Messages:
    22
    Location:
    Hell's Kitchen
    Country:
    United States
    Thanks for the quick response, but thats only between d2x and d2x alt... Im looking wich ones install to substitut my current cIOS like 249, 250 etc, do I have to substitute all of them with the beta for 2dx/2dx-alt? I mean, I want to know whic ones will improve my wii functionality in general, Im going for the d2x insted of alt, but I want to know if I can substitute all my current cIOS with d2xcIOS
     
  14. Cyan

    Global Moderator Cyan GBATemp's lurking knight

    Joined:
    Oct 27, 2002
    Messages:
    17,012
    Location:
    Engine room, learning
    Country:
    France
    usual recommendations for bases are :

    slot249 : based on IOS 56 (has the fastest USB read access and good compatibility)
    slot250 : based on IOS 57 (for few games not working with base56, like call of Duty. good compatibility but slower than base56)
    some users also install slot251 : based on IOS 58 (for some musical games). Bad speed, and bad compatibility. use only for games requiring IOS58 officially. (microphone, Wiispeak, etc.)

    For the version :
    v8 is very good and stable. Has only Port0 support.
    v9 is beta, adds Port1 support, adds more HDD support, but has less EmuNAND compatibility. So, for next version it has been split in two:
    v10 = v8 + more HDD support. Install this only if v8 doesn't work for you.
    v10-alt = v8 + more HDD support + Port1 support, but has less emuNAND compatibility. Use this if you need port1


    I recommend v8 if you don't need Port1 and your HDD works fine with it.
     
    hvy109 likes this.
  15. killerkalmah

    Newcomer killerkalmah Member

    Joined:
    Sep 3, 2014
    Messages:
    22
    Location:
    Hell's Kitchen
    Country:
    United States
    Once again this day... thanks Cyan, that was exactly what I was looking for, I will go for v10 since I still looking for a storage device and those I currently have are very odd, then, I will download the cIOS249(IOS56)d2xv10 is the best for compativility right? and I will go for cIOS250(IOS56)d2xv10 then since I don't mind cod and other uncmpatibles, or what would you suggest with that one?
     
  16. maverickbleh

    Newcomer maverickbleh Newbie

    Joined:
    Feb 4, 2010
    Messages:
    8
    Country:
    United States
    Cyan It worked like a charm, thank you so much for your help!
     
  17. airline38

    Member airline38 GBAtemp Advanced Fan

    Joined:
    Mar 28, 2010
    Messages:
    746
    Country:
    Taiwan
    As some people may be aware that current cIOSX d2x doesn't work
    for EmuNand of an UStealth drive.
    So I made a small mod of d2x fat module to solve this issue.
    I have tested on my Wii and vWii.They all worked no problem.

    If anyone would like to install this "small mod" version of d2x(v10),
    you can download the attached file (mod FAT module and source code)
    then use d2x cios installer to install yourself. (just simply replace the
    FAT.app with the original package from
    https://code.google.com/p/d2x-cios/downloads/list)
     

    Attached Files:

  18. Cyan

    Global Moderator Cyan GBATemp's lurking knight

    Joined:
    Oct 27, 2002
    Messages:
    17,012
    Location:
    Engine room, learning
    Country:
    France
    installing the same base of the same version in two different slot is useless.

    if you already have v10 base56 in slot249, you don't need to install it again in slot250.
    or maybe you forgot to write "-alt" somewhere?
    249 : v10 base56
    250: v10-alt base56
    in order to switch to slot 249 for emuNAND, and slot250 if you need port1?

    if you don't need port1 nor call of duty, don't bother installing something in slot 250.
    install only v10 base56 in 249.


    Airline:
    Thanks for making a new version for emuNAND.
    I will probably add it to another package, along with the other version. it will be easier for users.
     
    killerkalmah likes this.
  19. oji

    Member oji GBAtemp Regular

    Joined:
    Sep 1, 2012
    Messages:
    241
    Location:
    In Soviet Russia you're the Location
    Country:
    Russia
    Thanks a lot, airline38! Your patch works great.
     
  20. airline38

    Member airline38 GBAtemp Advanced Fan

    Joined:
    Mar 28, 2010
    Messages:
    746
    Country:
    Taiwan
    Actually you can copy/replace FAT.app to \ModMii\Support\d2x-beta
    then use ModMii to generate the cIOSX d2x wad file. (for Wii only)
     
    oji likes this.
  21. killerkalmah

    Newcomer killerkalmah Member

    Joined:
    Sep 3, 2014
    Messages:
    22
    Location:
    Hell's Kitchen
    Country:
    United States
    Ok I did it that way... works awesome for me, thanks for the help!
     

Share This Page