Bought 3 R4 cards, won't play games.

Discussion in 'R4 DS' started by Dead End, Mar 19, 2014.

Mar 19, 2014
    • Member

    Dead End New Member

    Member Since:
    Mar 12, 2009
    Message Count:
    440
    Location:
    Rockford IL.
    Country:
    United States
    Pointless back story
    I recently bought my 3 siblings each a DSi XL, all on 1.4.4 it seems and I got 3 R4 cards for each of them. They load up just fine, the DSi sees the icon it's supposed to have (Metroid?) But when they go to play any of the DS games (or even homebrew) It gets stuck on the black "Loading Screen". I have another DSi XL still on 1.4.3 and an R4 that works just fine on all of the DSi's, but the 3 new cards still get stuck on the Loading screen on any of the 3DS.

    Summary
    • Bought 3 R4 cards all from this site (as listed on Shoptemp): http://www.eachmall.me/goods-5651-5651.html
    • All 3 cards DO have the R4ids.cn on the stickers (Though I've taken the stickers off now so the kids can tell them apart)
    • All 3 DSi XL's are on Firmware 1.4.4 but I have one extra DSi still on 1.4.3
    • I have an extra card that's on the latest wood kernel (1.6.2) that works just fine
    Problem
    • The 3 cards are seen on the DSi's just fine, and have the latest Game Icon (Metroid Pinball is it?)
    • When I go to load anything such as a game or homebrew it gets stuck on the black "Loading Screen"
    • When I used the "R4iGold_3DS62_Patch_NDSL.nds" file to try to update the 3 of them it always says "Fail; Press KEY_A again"
    • The "R4iGold_3DS62_Patch_NDSL.nds" worked perfectly when I used it on the already working card.
    Is there anything I can do from here? Hopefully I gave enough details, if not then please let me know.
    I hope I can get this fixed soon, they were really excited to get their own DSi's and it keeps them from begging for my 3DS.
    • Member

    Apache Thunder I have cameras in your head!

    Member Since:
    Oct 7, 2007
    Message Count:
    718
    Location:
    Levelland, Texas
    Country:
    United States
    What file system do you have the MicroSD cards formatted as? Try doing a full format as FAT16 (if they are below 4GB in capacity, otherwise use FAT32). Uncheck the "Quick Format" option. Then copy all the games back. The only thing I can see is perhaps the files are fragmented too much. However DO NOT EVER USE DISK DEFRAGMENTOR ON A FLASH STORAGE DEVICE...EVER! Doing so is a quick way to destroying a flash based card like MicroSD. They have a finite amount of writes before they die plus the fact fragmentation does not alter it's seek/read speeds at all.

    The best way to defrag without using defragger, is to simply reformat and copy the files back.

    Also the connection to the SD cards may not be very good on the SD card slot of the flashcarts. Try inserting/removing the MicroSD from the R4s repeatedly to brake them in.

    Also make sure you are using the correct firmware. I would recommend WoodR4, but you have the DSi versions of them while I have the original R4. I don't know if WoodR4 also works with R4i, but I would happen to bet that it does.

    If that fails, try a different/better quality MicroSD card and check that the roms you are trying to use aren't corrupted somehow (though unlikely if you have a large number of them and they all fail). Check that they aren't "pre-patched". Prepatching isn't nessecery if you are using WoodR4 as it does auto fixes whatever AP measures most games have including Pokemon Black/White (Version 2 as well).

    If it still fails you may have defective hardware.
    Last edited by Apache Thunder, Mar 20, 2014
    • Member

    Dead End New Member

    Member Since:
    Mar 12, 2009
    Message Count:
    440
    Location:
    Rockford IL.
    Country:
    United States
    The SD cards themselves work, I've swapped them all around and used a couple on the working R4 card.

    As far as wood goes I'm not sure how to tell if they are running wood or not, but it does look like the Wood/acecard interface so they probably are. In that case it is the latest firmware, and the DSi's are on 1.4.4/1.4.5

    After doing what you reccomended they still won't work. :(
    I would assume contacting the site I bought them from for a refund would be close to impossible right? :/ (Seeing that they're China based)
    • Reporter

    Foxi4 Shotgun to the face is not a contingency plan.

    Member Since:
    Sep 13, 2009
    Message Count:
    19,534
    Location:
    Gaming Grotto
    Country:
    Poland
    R4iGold_3DS62_Patch_NDSL.nds is a patch for the NDS Lite, use the DSi patch, then report back. Namely, you're interested in R4iGold_3DS62_Patch_NDSi-3DS.nds. In addition, do try the cart out with a standard, non-SDHC card (capacity up to 2GB) - for whatever reason, some flash carts have problems with some SD cards and a non-SDHC should be enough to acertain whether the cart is borked or if the loading process is just terribly long.
    Last edited by Foxi4, Mar 20, 2014
    • Member

    Dead End New Member

    Member Since:
    Mar 12, 2009
    Message Count:
    440
    Location:
    Rockford IL.
    Country:
    United States
    Sorry I meant the DSi version, I copied the file name from another site to save time.

    I have 2gb cards for all of them. All bought from Amazon, since I know buying cards from some flash card sites inst always the best idea.

    And I've tried using at least one of the SD cards in the working card without doing anything to the files in it and it worked fine.
    Last edited by Dead End, Mar 20, 2014
    • Member

    Pong20302000 i might be a Horcrux

    Member Since:
    Sep 8, 2009
    Message Count:
    8,073
    Location:
    One's inner self
    Country:
    Japan
    it most likely is MicroSD card corruption or Fake MicroSD cards and the transfer speed is Too Slow
    you often find that Amazon you will get MicroSD fakes

    corruption is also caused on the Wood Kernel by extracting straight to the MircoSD
    you MUST extract the to desktop first and then copy the Kernel to the MicroSD

    also make sure you are placing the Kernel on the MicroSD correctly and not putting anything in a folder

    also Wood 1.64 is the latest Wood
    • Member

    kirbymaster101 New Member

    Member Since:
    Dec 21, 2008
    Message Count:
    963
    Country:
    Canada
    try panasonic sd card formatter to format the card and report back the results.
    • Newcomer

    Rezatron New Member

    Member Since:
    Oct 12, 2012
    Message Count:
    70
    Country:
    Canada
    @kirbymaster101 his older R4 is working fine with the same microSD which means it's probably a kernel issue

    What is the website on your "working" (4th) R4? Is it different than r4ids.cn? If so, use the version of Wood available at r4ids.cn

    I'm not 100% on this but certain Wood versions will only work for certain card. Like the Wood kernel available at r4ds.com may not work properly with cards from r4ids.cn or r4idsn.com
    Last edited by Rezatron, Mar 21, 2014
    • Member

    Dead End New Member

    Member Since:
    Mar 12, 2009
    Message Count:
    440
    Location:
    Rockford IL.
    Country:
    United States
    Ok before I do anything with the SD cards, as Rezatron reiterated, all of the SD cards do work in the working R4 card. It's just that the 3 card don't want to load anything at all. I can boot the card up and look at all the games, but I can't load anything.

    The website is R4ids.cn just like the others. I couldn't order the new cards from the same site since that site isn't listed anymore and likely doesn't sell the cards anymore. I tried the wood firmware that they have on that site bu no luck so far, but it does work on the working card.

SPONSORED LINKS
 

Share This Page