Announcing RocketLauncher! The first exploit with unlocked Arm7!

Discussion in 'NDS - Emulation and Homebrew' started by Apache Thunder, Jul 2, 2017.

  1. Robz8

    Robz8 Coolest of TWL

    Member
    6,693
    2,829
    Oct 1, 2010
    United States
    Nope.
     


  2. TheLegendofMario

    TheLegendofMario GBAtemp Regular

    Member
    143
    41
    May 15, 2016
    United States
    So is it going to be able to install this without a Flashcart? My DSi has a completely shot cartridge slot
     
  3. PoppaDre

    PoppaDre GBAtemp Regular

    Member
    146
    58
    Aug 23, 2016
    Canada
    So I can currently use my R43DSi card on my DSi. Was this patched at some point? This RocketHax will let me load games of the SD card instead? I think I'm understanding it now
     
  4. Apache Thunder
    OP

    Apache Thunder I have cameras in your head!

    Member
    4,101
    4,024
    Oct 7, 2007
    United States
    Levelland, Texas
    No. A functional card slot is required.
     
  5. Oleboy555

    Oleboy555 Wie dit leest is een zemmel

    Member
    638
    268
    Feb 8, 2017
    Netherlands
    Amsterdam
    no, SRLoader does that
     
  6. PoppaDre

    PoppaDre GBAtemp Regular

    Member
    146
    58
    Aug 23, 2016
    Canada
    Wow I know nothing of the DS scene other than flashcarts
     
  7. Robz8

    Robz8 Coolest of TWL

    Member
    6,693
    2,829
    Oct 1, 2010
    United States
    which can be ran via RocketLauncher.
     
    Oleboy555 likes this.
  8. FateForWindows

    FateForWindows GBAtemp Advanced Fan

    Member
    545
    203
    Feb 8, 2017
    United States
    I watched the video already. Cool exploit.
     
  9. Robz8

    Robz8 Coolest of TWL

    Member
    6,693
    2,829
    Oct 1, 2010
    United States
    RocketLauncher is now in the latest news on DSiBrew!
     
    Last edited by Robz8, Jul 7, 2017
    I pwned U!, MyDePain, julialy and 4 others like this.
  10. aea

    aea Advanced Member

    Newcomer
    57
    17
    Feb 8, 2013
    Uhm, I see. Well, I'll have then to wait for the upcoming exploits and hope that my old and trusty DSTTi to be between the compatible flashcarts to take advantage of these exploits. Thanks and keep the good work guys.
     
  11. Robz8

    Robz8 Coolest of TWL

    Member
    6,693
    2,829
    Oct 1, 2010
    United States
    If you have another DS family console and flashcard, you can use HaxxStation.
     
  12. pandavova

    pandavova @pandavova FOLLOW ME ON TWITTER

    Member
    561
    249
    Oct 27, 2015
    Germany
    Windows 10 Pro
    Hmm... I forgot the HaxxStation... This could change some things...
     
  13. Billy Acuña

    Billy Acuña GBAtemp Addict

    Member
    2,175
    1,278
    Oct 10, 2015
    Mexico
    Or a Wii/Wii U.
     
  14. aea

    aea Advanced Member

    Newcomer
    57
    17
    Feb 8, 2013
    I actually have several NDS family consoles and I have also heard about Haxxstation, but If I'm not wrong it cannot install the DSi Homebrew Channel because that expoit only works in DS mode. Please correct me if I'm wrong.
     
  15. Robz8

    Robz8 Coolest of TWL

    Member
    6,693
    2,829
    Oct 1, 2010
    United States
    Yep, you're right.
     
  16. aea

    aea Advanced Member

    Newcomer
    57
    17
    Feb 8, 2013
    Ok, thanks.
     
  17. finkmac

    finkmac GBAtemp Fan

    Member
    457
    122
    Nov 9, 2011
    Canada
    Over there
    hrm okay, what about if you're on 1.3?
     
  18. Robz8

    Robz8 Coolest of TWL

    Member
    6,693
    2,829
    Oct 1, 2010
    United States
    Nope. It's 1.4 only.
     
  19. gothicall

    gothicall Blah blah blah!

    Member
    213
    31
    Apr 29, 2010
    Colombia
    You sir, have my respect
     
  20. R0B0T0

    R0B0T0 Advanced Member

    Newcomer
    78
    9
    Nov 21, 2005
    United States
    I have a 1.4 console, but I'm confused by:

    "Note you will either need a nand mod or a DSiWare based exploit to downgrade your console/install the modified white list needed for this to work"

    Does this mean 'downgrade the console IN ORDER TO install the whitelist' (meaning since I don't need to downgrade, nand mod/dsiware exploit are not required)

    Or 'downgrade the console AS WELL AS install the whitelist' (meaning even if you don't need to downgrade, you still need nand mod or dsiware exploit just for the whitelist install)?
     
    pandavova likes this.