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Overview: 
 
In this guide I will go over how to use Scribus to assemble your cards into a PDF. The goal of this guide is to have a print 
ready pdf with all your cards in it so you can print it at home or take it to a professional printing place and have it printed 
there. The actual layout of the cards on the page is performed when you go to print your PDF. The PDF print dialog will 
automatically lay out the cards for us. This way if you decide later that you actually want to print on a larger sheet of 
paper you don’t have to recreate your PDF, the PDF printer dialog will automatically adjust the layout of the cards to fit 
the new size of paper. 
 
If you have access to Acrobat Pro you can use that software instead. It is equivalent to combining the image files into a 
PDF. However that software is not free so I will not cover how to use it. A word of caution though, the default behavior 
of Acrobat Pro is to compress the images as you create the PDF you will have to change that setting if you want good 
quality prints. 
 
If you know the size of paper you are going to be printing on and want to lay out the cards on the page in Scribus I will 
briefly go over how to make a template for a Letter size page with 6 cards on it at the end of this guide. However I only 
suggest doing this if you are really sure you won’t be changing the page size. 

  



How to create your own custom template for Scribus: 
 
Download and install the Scribus software from: https://www.scribus.net/ (There is a portable version too) 
 
When you first run the software it will show you the New Document window. We will want to create a document that is 
the size of our cards.  
 
I like to work in centimeters so the first thing I am going to do is change the Default Unit to centimeters. 
 

 
 
Next we need to set up the Document size. Personally, I am going to be printing cards that will be 6.2 cm wide by 8.7 cm 
tall.  So I am going to enter in 6.2 as a width and 8.7 as a height. For “Margin Guides” I am going to enter 0 for all fields 
(the margins will be set later). 
 

 
 
The images I am using are actually 7.2 cm wide and 9.7 cm tall. They were designed with an extra 0.5 cm on all sides that 
is meant to be cut off after printing. This extra bit of the image is called a bleed. Having bleeds allows you to have a little 
play room when cutting if you aren’t that accurate. So I am going to go to the “Bleeds” tab next to the “Margin Guides” 
tab and enter in 0.5 cm for my bleeds. 
 

https://www.scribus.net/


 
 
I know I want to print out 6 playing cards. Because each card will need a front and a back I am going to need 12 pages. 
You can always add or remove pages later but since I already know how many I will need I am going to set that value 
now. 
 

 
 
Now that we have finished setting up the document settings click the “ok” button. Our new document will be created 
with 12 blank pages. 
 
We will need to be able to add our card images onto the page. To do that we will first need to add an image frame to 
each page. The image frame holds the card image. Go to “Insert>Frames…” in the main menu. The Insert Frames Dialog 
will appear. In the “Type” tab choose “Image Frame”. In the “Location” tab choose the “All Pages” option for the page 
placement. In the same tab choose “Top Left of Bleed” for the “Position of Frame”. If your images don’t have a bleed 
choose “Top Left of Page” instead. In the “Size” tab choose “Same as the Bleed”. Again if your images don’t have a bleed 
choose “Same as the Page”. Now click Ok. 
 
 



 
 
Now we have 12 pages with image frames on them.  
 

 
 
When laying out the cards I personally like to put the front image and back image of the cards next to each other. So if I 
put the front of card ‘A’ on page 1, the back for card ‘A’ will be on page 2. However I also like to rotate the backs 180 
degrees. So before I add the images to the frames I will want to set it up so that every other image is rotated 180 
degrees.  
 
To have the image rotated open the properties window by pressing F2. Make sure you have the second page’s image 
frame selected so that you are editing that frames properties. The easiest way to rotate the image 180 degrees is to 

have the image flipped both horizontally and vertically. You can do this by pressing both  and  in the properties 
window. Do this for every other page (all the even pages). You can leave the properties window open, just click on an 
image frame to edit its properties. 
 



 
 
Now that the file is set up save it as a template so you can use it again later if you need to. First you will want to check 
where Scribus looks for templates. Go to “File>Preferences” and look for the “Document Templates” path. I installed the 
portable version so mine is set to “C:\PortableApps:\ScribusPortable\Data\Templates” 
 

 
 
Now go to “File>Save as Template” and open the save dialog. Navigate to the template directory. Create the directory if 
it doesn’t exist.  Enter a name for the folder your template will be placed in, click ok. 
 

 



 
Now it will ask you to actually save the template. Give the actual template a name, this name will show up in your 
template list. Click Ok when you are done. 
 

 
 
Now the template we just made will appear if you choose to create a new document from a template 
 

 
  



How to use a template in Scribus: 
 
Download and install the Scribus software from: https://www.scribus.net/ (There is a portable version too) 
 
Run Scribus. The new dialog box will appear. If you have already installed a template you wish to use you can select it 
from the “New From Template” tab.  
 
If you still need to install your template, close the “New Document” dialog by pressing “Cancel”. Go to 
“File>Preferences…” and look for the “Document Templates” path. 
 

 
 
Copy the template you have to this directory. If the directory does not exist, create the directory. Then choose 
“File>New From Template” from the main menu. Choose your template from the template list and click ok. 
 

 
 
A new document will be created from the template. It should have multiple pages in the document and each page 
should have an image frame on it. The image frame looks like an X and is where we will place our images. 
  

https://www.scribus.net/


How to export your cards to be print-ready:  
 
If you are here, you should have the Scribus software open and your document should have a number of pages in it with 
image frames on each page. If you need help getting to this point please see the previous steps. 
 
We need to put the images from our cards into the image frames. The easiest way to do this is to open up a folder with 
your images in them and snap it to one side of your screen. Then snap Scribus to the other side. 
 

 
 
Now just drag and drop your files onto the frames they belong to. You can drop the image anywhere inside the card 
frame and it will be placed correctly. The card backs will be rotated automatically when you place the image, if your 
template was set up that way. 
 
Note: As you drag your images into place you may realize the images look very low quality. This is a feature to allow the 
program to run faster. If you would like to see the actual quality of the image: right click the image frame and choose 
“Preview Settings>Full Resolution” 
  



 
 
My image files were created at 300 dpi. The dpi of an image is usually stored inside the image’s meta data. If the image 
is saved correctly programs like Scribus can read the intended dpi and display the image at the correct size. However 
depending on where you got your images from, the dpi might not have been saved to the image’s meta data properly. In 
that case the image will be treated as a 72 dpi image and appear oversized.  
 

 
 
If this happens, open the properties window by pressing F2. Select the image frame of the card that is being displayed 
incorrectly. In the properties dialog, find the “Image” tab near the bottom. Inside the “Image” tab, change the “Actual X-
DPI” and “Actual Y-DPI” to the correct dpi, in this case 300. This will restore the intended dpi of the image and should 
make the image appear correctly sized in the frame. 
 



 
 
Once you finish dragging your images into place we need to export the cards to PDF so we can get them printed. 
 
Go to “File>Export>Save As PDF…” to open the save dialog. On this dialog you will want to double check that the 
“Compression Method” is set to “None” or “Lossless - Zip” and the “Compression Quality” is set to Maximum. 
 

 
 
Under the “Pre-Press” tab you will also want to make sure “Use Document Bleeds” is checked. This will make the images 
have the bleed space in the PDF. If for some reason you do not want to print the bleed area you can leave this setting 
unchecked and set the bleeds to zero. This will output the cropped images to the PDF. But since I want the bleed to be in 
the final print I will leave this value checked. 
 



 
 
Now you have a print ready PDF. 
  



Printing your PDF: 
 
In order to print your PDF open it in Acrobat Reader. Go to “File>Print”. 
 
In the print dialog for “Page Sizing & Handling” choose “Multiple”. For “Pages per sheet” choose 6. Set “Page Order” to 
“Vertical”. Now hit print. 
 
NOTE: With my playing cards I can only fit 6 pages per letter size sheet of paper. If I tried to fit more, then Acrobat would 
start scaling the cards. With smaller cards or bigger paper you may be able to fit more without the cards getting scaled. 
Unfortunately the only way to tell if the cards are being scaled is to print a test and compare it. So some 
experimentation will be required if you want to try other layouts. I would suggest using a “Print to PDF” or some other 
“Print to File” option to test the sizes so you don’t waste paper or ink. Your printer’s minimum margin size will also 
affect how many cards can fit on a single sheet of paper before being scaled. 
 
Also in the “Pages to Print” section, if you choose to only print a specific page, that page number corresponds to the 
card. So if you only wanted to print the first card and its card back, you would put “1, 2” in the “Pages” field. 
 

 
  



Creating a template for a specific page size in Scribus: 
 
This will go over how to use Scribus to make a template that will lay out cards on a set size of paper. If you already 
followed the previous steps in this guide and have a print ready PDF you can skip this section. 
 
Open Scribus. See “How to create your own custom template for Scribus” earlier in this guide if you need help getting 
the software. 
 
In the “New Document” dialog choose your paper size. I am choosing Letter landscape. I am also going to set the 
“Default Unit” to centimeters and set all the margins to 1 cm. Your margins might have to be larger depending on your 
printer. 
 

 
 
I will then choose “Insert>Image Frame” from the main menu and then click anywhere inside the page. My cards are 
meant to be 6.2 cm by 8.7 cm after cutting them out but they have an extra 0.5 cm bleed making the images actually 7.2 
cm by 9.7 cm. So in the image frame dialog I will enter 7.2 cm and 9.7 cm. 
 

 
 
Go to “Page>Snap to Guides” and make sure it’s checked. This will make it easier to position the image frames. 
 

 
 
Now drag the image frame to the top left margin corner. It should snap into place. 
 



 
 
With the image frame selected go to “Item>Multiple Duplicate” and in the “By Rows & Columns” tab enter 2 for rows, 3 
columns and click ok. This will make copies of the image frame and place them on your page. 
 

           
 
Now drag the image frames to the edges of the margin. For the centre image frames the horizontal position isn’t really 
important as we will set it more precisely later. 
 



 
 
To centre the middle frames properly we will first need to find the exact width of the page. Go to “File>Document 
Setup…” and remember the “Width” value. For my page it is set to 27.94cm. Now that we have the width we can close 
the dialog. 
 

 
 
Select the top middle image frame. Open the properties window in order to edit the properties of the image frame. You 
can open the properties window by pressing F2. In the properties window change the “Basepoint” to the centre. This 
will make the “X-Pos” and “Y-Pos” relative to the centre of the image frame. Since we looked up the width of the page 
we can divide that number by two in order to find out the exact centre of the page. In my case the centre of the page 
will be 13.97 cm. Now enter the value for the centre of the page in the “X-Pos” field in the properties window. 
 



 
 
This will centre the image frame. Repeat these steps for the image frame in the bottom middle. 
 

 
 
Now you have a template that will print 6 cards on a single letter size page. Follow the steps laid out earlier in this guide 
to learn how to save this as a template and add images to the document. 


	Overview:
	How to create your own custom template for Scribus:
	How to use a template in Scribus:
	How to export your cards to be print-ready:
	Printing your PDF:
	Creating a template for a specific page size in Scribus:

